Bug 1884251 - Multiple SRIOV tests failed in discovery mode
Summary: Multiple SRIOV tests failed in discovery mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: CNF Platform Validation
Version: 4.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Federico Paolinelli
QA Contact: Nikita
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-01 12:54 UTC by Nikita
Modified: 2020-10-27 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Logs from cluster (3.71 MB, text/plain)
2020-10-01 12:54 UTC, Nikita
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 364 0 None closed Bug 1884251: Conformance test: make sure that the hostnetwork pod and the test pod run on the same node. 2020-10-07 03:45:35 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:34 UTC

Description Nikita 2020-10-01 12:54:17 UTC
Created attachment 1718165 [details]
Logs from cluster

Description of problem:

Multiple SRIOV tests failed in discovery mode. 


Version-Release number of selected component (if applicable):

Server Version: 4.6.0-fc.8
Kubernetes Version: v1.19.0+359dd79

CNF test container version: 
registry-proxy.engineering.redhat.com/rh-osbs/openshift4-cnf-tests:v4.6.0-15

How reproducible:
Run cnf tests image with focus flag sriov:
docker run -v /tmp/reports:/report -v /tmp/kubeconfig:/kubeconfig/ -e KUBECONFIG=/kubeconfig/kubeconfig -e DISCOVERY_MODE=true -e IMAGE_REGISTRY=registry-proxy.engineering.redhat.com/rh-osbs -e CNF_TESTS_IMAGE=openshift4-cnf-tests:v4.6.0-15 registry-proxy.engineering.redhat.com/rh-osbs/openshift4-cnf-tests:v4.6.0-15 /usr/bin/test-run.sh -ginkgo.focus="sriov" --report=/report --junit=/report


Steps to Reproduce:
1. Run tests
2. Wait until all tests are done
3. Collect summary. See below:

Summarizing 4 Failures:

[Fail] [sriov] operator Generic SriovNetworkNodePolicy VF flags [It] Should configure the spoofChk boolean variable 
/remote-source/app/vendor/github.com/openshift/sriov-network-operator/test/conformance/tests/sriov_operator.go:300

[Fail] [sriov] operator Generic SriovNetworkNodePolicy VF flags [It] Should configure the trust boolean variable 
/remote-source/app/vendor/github.com/openshift/sriov-network-operator/test/conformance/tests/sriov_operator.go:300

[Fail] [sriov] operator Generic SriovNetworkNodePolicy VF flags [It] Should configure the the link state variable 
/remote-source/app/vendor/github.com/openshift/sriov-network-operator/test/conformance/tests/sriov_operator.go:300

[Fail] [sriov] operator Generic SriovNetworkNodePolicy VF flags vlan and Qos vlan [It] Should configure the requested vlan and Qos vlan flags under the vf 
/remote-source/app/vendor/github.com/openshift/sriov-network-operator/test/conformance/tests/sriov_operator.go:300

Ran 11 of 74 Specs in 497.009 seconds
FAIL! -- 7 Passed | 4 Failed | 0 Pending | 63 Skipped
 

Actual results:


Expected results:
All discovery tests passed 

Additional info:
Log attached

Comment 1 Federico Paolinelli 2020-10-01 14:00:00 UTC
It's a flake.
Flag tests run a hostnetwork pod to do the verification and one test pod to ask the configuration.

It works when both happen to run on the same node, it does not if they run on different nodes.

This is an example of a bad run:

sriov-conformance-testing                          testpod-cwk87                                                                1/1     Running     0          41s     10.1.190.15    worker-0.cluster1.savanna.lab.eng.rdu2.redhat.com   <none>           <none>
sriov-conformance-testing                          testpod-whqq2                                                                1/1     Running     0          39s     10.128.3.109   worker-1.cluster1.savanna.lab.eng.rdu2.redhat.com   <none>           <none>

Comment 4 Nikita 2020-10-07 09:10:24 UTC
Tested with openshift4-cnf-tests:v4.6.0-19 registry-proxy.engineering.redhat.com/rh-osbs/openshift4-cnf-tests:v4.6.0-19
SRIOV tests looks good. Move this task to Done

Comment 6 errata-xmlrpc 2020-10-27 16:47:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.