Bug 1884272 - IPv6 OVN deployments failing due to malformed IP
Summary: IPv6 OVN deployments failing due to malformed IP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Tim Rozet
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-01 13:59 UTC by Steven Hardy
Modified: 2020-10-27 16:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 817 0 None closed Bug 1884272: Fixes double bracketify on init_ips 2021-02-08 11:49:19 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:40 UTC

Description Steven Hardy 2020-10-01 13:59:57 UTC
Description of problem:

https://github.com/openshift/cluster-network-operator/pull/806 was merged with failing CI and appears to have broken ipv6 deployments due to errors in the bracket logic.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Check CI results for e2e-metal-ipi which uses OVN and ipv6
2. See a failure like https://github.com/openshift/cluster-network-operator/pull/806#issuecomment-698687886

The underlying cause having reproduced locally seems to be this:
$oc describe pod ovnkube-master-5dk26
...
ovnkube-master-vg7c9 is part of current cluster with ip: [fd2e:6f44:5dd8:c956::14]!
+ echo 'ovnkube-master-vg7c9 is part of current cluster with ip: [fd2e:6f44:5dd8:c956::14]!'
+ return 0
+ cluster_found=true
+ break
+ true
+ echo 'Cluster already exists for DB: nb'
Cluster already exists for DB: nb
+ initial_raft_create=false
++ bracketify fd2e:6f44:5dd8:c956::16
++ case "$1" in
++ echo '[fd2e:6f44:5dd8:c956::16]'
++ bracketify '[fd2e:6f44:5dd8:c956::14]'
++ case "$1" in
++ echo '[[fd2e:6f44:5dd8:c956::14]]'
+ exec /usr/share/ovn/scripts/ovn-ctl --db-nb-cluster-local-port=9643 --db-nb-cluster-remote-port=9643 '--db-nb-cluster-local-addr=[fd2e:6f44:5dd8:c956::16]' '--db-nb-cluster-remote-addr=[[fd2e:6f44:5dd8:c956::14]]' --no-monitor --db-nb-cluster-local-proto=ssl --db-nb-cluster-remote-proto=ssl --ovn-nb-db-ssl-key=/ovn-cert/tls.key --ovn-nb-db-ssl-cert=/ovn-cert/tls.crt --ovn-nb-db-ssl-ca-cert=/ovn-ca/ca-bundle.crt '--ovn-nb-log=-vconsole:info -vfile:off' run_nb_ovsdb
ovsdb-tool: ovsdb error: ssl:[[fd2e:6f44:5dd8:c956::14]]:9643: syntax error in address
2020-10-01T12:50:01Z|00001|vlog|INFO|opened log file /var/log/ovn/ovsdb-server-nb.log
ovsdb-server: I/O error: /etc/ovn/ovnnb_db.db: open failed (No such file or directory)


Actual results:

The IP is malformed e.g 

ovsdb-tool: ovsdb error: ssl:[[fd2e:6f44:5dd8:c956::14]]:9643: syntax error in address

Expected results:

The bracket logic needs to be fixed for ipv6 to function correctly.

Additional info:

Comment 3 Anurag saxena 2020-10-09 06:23:18 UTC
Hi Arik, could you team help verify this bug?

Comment 5 errata-xmlrpc 2020-10-27 16:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.