Bug 1884278 - Import from registry fails for specific quay.io images
Summary: Import from registry fails for specific quay.io images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: Storage
Version: 2.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 2.5.0
Assignee: Tomasz Barański
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-01 14:18 UTC by Alex Kalenyuk
Modified: 2020-11-17 13:25 UTC (History)
5 users (show)

Fixed In Version: virt-cdi-operator-container-v2.5.0-17 hco-bundle-registry-container-v2.5.0-329
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-17 13:24:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
importer-pod-log (9.37 KB, text/plain)
2020-10-01 14:18 UTC, Alex Kalenyuk
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github kubevirt containerized-data-importer pull 1413 0 None closed Fix imports for images with no info about MediaType. 2021-01-11 12:58:52 UTC
Red Hat Product Errata RHEA-2020:5127 0 None None None 2020-11-17 13:25:06 UTC

Description Alex Kalenyuk 2020-10-01 14:18:12 UTC
Created attachment 1718188 [details]
importer-pod-log

Description of problem:
Importing specific registry images from quay.io fails

Version-Release number of selected component (if applicable):
2.5.0

How reproducible:
100%

Steps to Reproduce:
1. Create DV that imports from registry (specific image described below)
2.
3.

Actual results:
Import stuck in "ImportInProgress" with errors in importer pod log

Expected results:
Import successful

Additional info:
2.5.0 -> Fails
2.4.1 -> Same image gets imported successfully

Importer log attached

[cnv-qe-jenkins@akalenyu251-8hn8j-executor registry-fails-2.5]$ cat dv_public.yaml 
apiVersion: cdi.kubevirt.io/v1beta1
kind: DataVolume
metadata:
  name: import-registry-quay-dv
spec:
  source:
    registry:
      url: docker://quay.io/kubevirt/cirros-registry-disk-demo
  pvc:
    accessModes:
    - ReadWriteOnce
    resources:
      requests:
        storage: 5Gi
    storageClassName: hostpath-provisioner
    volumeMode: Filesystem
  contentType: kubevirt

Comment 1 Tomasz Barański 2020-10-01 14:36:17 UTC
This image's layers have `MediaType` field empty.

Comment 3 Alex Kalenyuk 2020-10-13 15:03:43 UTC
Verified on CNV 2.5.0, KubeVirt: v0.34.0-13-g2cc7d61, CDI: Containerized Data Importer v1.23.6
HCO-v2.5.0-329
HCO image: registry.redhat.io/container-native-virtualization/hyperconverged-cluster-operator@sha256:631d9868743d52fba5fb5a089acc418328e0c33c55ae2319e5e06c24a4323124
CSV creation time: 2020-10-11 19:19:07

Comment 6 errata-xmlrpc 2020-11-17 13:24:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Virtualization 2.5.0 Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:5127


Note You need to log in before you can comment on or make changes to this bug.