Bug 1884327 - Screen sharing portal window doesn't show in Firefox on Fedora 33 Wayland
Summary: Screen sharing portal window doesn't show in Firefox on Fedora 33 Wayland
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-01 16:57 UTC by AM
Modified: 2020-11-08 07:53 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-02 19:41:01 UTC
Type: Bug


Attachments (Terms of Use)

Description AM 2020-10-01 16:57:06 UTC
Description of problem:
The system screen sharing window doesn't appear when I try to share it using Firefox. It is, from what I can tell, this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1806916, except it applies to Fedora 33 and Firefox 81.

Version-Release number of selected component (if applicable):
Fedora 33 beta 1.3
Firefox 81.0-6
Pipewire 0.3.13

How reproducible:
Always

Steps to Reproduce:
1. Go to Mozilla's GUM test page (https://mozilla.github.io/webrtc-landing/gum_test.html)
2. Try to share the screen using the "Screen capture" button
3. You will get Firefox's pop-up to allow it, but not the system one that lets pipewire through

Actual results:
The screen isn't shared.

Expected results:
GNOME's screen sharing window appears and allows me to select a screen to share.

Additional info:
None

Comment 1 Martin Stransky 2020-10-02 07:31:53 UTC
Works for me on Fedora 33 / Firefox 81.0-9. There's another popup created by system where you need to enable the screensharing...so there are actually two places where you need to enable it.

Comment 2 AM 2020-10-02 19:41:01 UTC
Thanks! Yep, I take that back. After doing updates it works now. It didn't work on the live image.

Comment 3 Nirmal Pathak 2020-11-08 07:53:36 UTC
This doesn't work for me on "Fedora 33 (Workstation Edition)". It was working on Fedora 32 & even after upgrade to Fedora 33, it was worked for few days. After some package updates it stopped working.

$ pipewire --version
pipewire
Compiled with libpipewire 0.3.14
Linked with libpipewire 0.3.14

$ firefox --version
Mozilla Firefox 82.0.2

Window System: Wayland
Kernel Version: 5.8.18-300.fc33.x86_64


Note You need to log in before you can comment on or make changes to this bug.