Bug 1884413 - VPA manifest failing validation
Summary: VPA manifest failing validation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Joel Smith
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-01 21:36 UTC by Joel Smith
Modified: 2020-10-27 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift vertical-pod-autoscaler-operator pull 36 0 None closed Bug 1884413: Update manifests to pass validation and allow direct upgrades 2020-12-08 02:06:20 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:40 UTC

Description Joel Smith 2020-10-01 21:36:44 UTC
Description of problem:
ART builds of the VPA operator are flunking one of the validation steps because the API version doesn't match the example provided in the metadata. Here's the error message:

time="2020-09-29T07:57:37Z" level=error msg="Error: Value autoscaling.k8s.io/v1beta2, Kind=VerticalPodAutoscaler: example must have a provided API"

Which comes from:

http://external-ci-coldstorage.datahub.redhat.com/cvp/cvp-redhat-operator-bundle-image-validation-test/ose-vertical-pod-autoscaler-operator-metadata-container-v4.6.0.202009290409.p0-1/44b88a2e-9213-4b63-92c7-4e2e32f74a9f/operator-metadata-linting-bundle-image-output.txt

Also, although the operator supports upgrading directly from 4.5.z to 4.6.z, its manifest prohibits it from doing so.

Version-Release number of selected component (if applicable):
4.6.0

How reproducible:
100%

Comment 6 errata-xmlrpc 2020-10-27 16:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.