Bug 18845 - Xconfigurator --expert does not accept specified card
Xconfigurator --expert does not accept specified card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 15:48 EDT by Jennifer E. Lamb
Modified: 2007-04-18 12:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 16:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jennifer E. Lamb 2000-10-10 15:48:05 EDT
Xconfigurator --expert does not accept the specified video card.  If you
check the configuration file, it defaults back to the card that was
originally probed.
Comment 1 Michael McConachie 2000-10-11 13:54:51 EDT
I've done some kicking on Xconfigurator last night.  It looks like it is taking
the card selected in --expert but it is using the name that it found in the
autoprobe for the Device string in the /etc/X11/XF86Config file it writes out..

I also discovered that if the --card "cardname" option is used, Xconfgiurator
uses "My Video Card" for the Device.

Oh, and the custom monitor screen's custom sync subscreen doesn't have any
sanity checking.  Things like "Bill", "bob", "whosymomma" and "johnboy!" are
passed right through to the config file ;)  It does, however, still ask about
probing for screen resolutions.

Using --monitor "monitor name" doesn't seem to have any effect.  The monitor
selection screen is still put up and the entries given there override the
monitor supplied on the command line.

Command lines used to test this:
	Xconfigurator --monitor "ViewSonic G773" --card "ATI Rage 128"
	Xconfigurator --monitor "COMPAQ V900 Color Monitor" --card "Cirrus Logic
GD542x"
	Xconfigurator --monitor "Samtron SC-728FXL" --card "Hercules Dynamite
128/Video"
	Xconfigurator --expert
In the last case, I selected a Cirrus Logic card and Cirrus Logic settings were
written to the XF86Config:

     # Device configured by
Xconfigurator:                                                                                       	
Section "Device" 
	Identifier  "3Dfx Interactive, Inc.|Voodoo 3" 
	VendorName  "Unknown" 
	BoardName   "Unknown" 
	#VideoRam    16384
	# Use Option "no_bitblt" if you have graphics problems. If that fails
	# try Option "noaccel".
	# Refer to /usr/X11R6/lib/doc/README.cirrus. 
	# To allow linear addressing, uncomment the Option line and the 
	# address that the card maps the framebuffer to. 
	    # Insert Clocks lines here if appropriate
     EndSection                                  
Comment 2 Rob Landry 2000-10-11 15:24:08 EDT
It also doesn't correct the symlink for /etc/X11/X to the correct XF86_XXXX
server (when used to configure 3.3.6).
Comment 3 Trond Eivind Glomsrxd 2000-10-17 16:03:28 EDT
If you enter a bad syncrange, like "bob" you get what you are asking for. That's
not a bug.

"--card" and "--monitor" are kickstart-only arguments. Not a bug.

I'll look into the other issues.

Comment 4 Trond Eivind Glomsrxd 2000-10-25 18:22:42 EDT
Fixed in CVS. Will eventually be 4.4.4 or higher
Comment 5 Need Real Name 2001-03-20 14:06:50 EST
I am having a trouble with my video card which is Trident975.
Whenever I select the modes of the card ( 256colors, or 16 bit or 24 bit), i can't keep going over that point.
There has been always an error comes up on the screen saying that I might have the problem with the xconfiguration setting and let me to go back to the 
previous menus.
Comment 6 Trond Eivind Glomsrxd 2001-03-20 14:15:37 EST
If so, please submit a separate bug on that.
Comment 7 Need Real Name 2001-09-08 09:25:11 EDT
During installation I noticed that my video card was found. During Xconfig when 
it got to the section about a Monitor, nothing i do here seems to work. So I 
skiped the X test hopeing that it was ok to do so. I got the ensurance that I 
had finished the setup. When I try to run the program it will start loading 
Linux but stop because of an "Error 0x10" and would try loading again.
   What did I do worng.

            Derrick H.
Comment 8 Need Real Name 2001-09-08 09:47:46 EDT
 I like to thank you for your quick response to my problem. I am sorry if I 
sound stupid but I have no idea what you anr talkin about. I am very new at 
this Linux thing ( 1st time install) Do I need to reinstall program? change 
mointor? What does this mean in dumb laymen terms "Xconfigurator --expert does 
not accept the specified video card.  If you @@ -87,3 +87,13 @@" please explain!

Note You need to log in before you can comment on or make changes to this bug.