Bug 1884529 - CNF test container | PTP discovery mode | PTP profile test in discovery mode
Summary: CNF test container | PTP discovery mode | PTP profile test in discovery mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: CNF Platform Validation
Version: 4.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Federico Paolinelli
QA Contact: Nikita
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-02 08:32 UTC by Nikita
Modified: 2020-10-27 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ptp-operator pull 73 0 None closed Bug 1884529: Skip the higher profile priority test in discovery mode 2020-10-07 09:10:48 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:40 UTC

Description Nikita 2020-10-02 08:32:58 UTC
Description of problem:
Test that requires reconfiguration added to Discovery mode. We need to skip it

Version-Release number of selected component (if applicable):
registry-proxy.engineering.redhat.com/rh-osbs/openshift4-cnf-tests:v4.6.0-15

How reproducible:
Run ptp test in discovery mode and get the test failure
[Fail] [ptp] PTP e2e tests PTP Interfaces discovery [It] Can provide a profile with higher priority
/home/fedepaol/devel/openshift/ptp-operator/test/ptp/ptp.go:232

Steps to Reproduce:
1. Run test with ptp focuse
2. get the error
3.

Actual results:


Expected results:
PTP Profile test should be excluded 

Additional info:

Comment 3 Nikita 2020-10-07 10:03:09 UTC
Verified with version openshift4-cnf-tests:v4.6.0-19 registry-proxy.engineering.redhat.com/rh-osbs/openshift4-cnf-tests:v4.6.0-19
Issue is fixed.

Comment 5 errata-xmlrpc 2020-10-27 16:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.