Bug 188454 - Interface names eth0, eth1 assigned randomly at boot time
Interface names eth0, eth1 assigned randomly at boot time
Status: CLOSED DUPLICATE of bug 187550
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 03:52 EDT by Stefan Behrens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 11:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Behrens 2006-04-10 03:52:38 EDT
Description of problem:
The interface names eth0, eth1 get assigned randomly at boot time.
Sometimes eth0 is fixed FE and eth1 is the wireless interface;
sometimes vice versa.
This is despite the fact that I have the following default settings
in modprobe.conf:
 alias eth0 via-rhine
 alias eth1 ipw2100


Version-Release number of selected component (if applicable):
Don't know what causes this bug.

How reproducible:
Always

Steps to Reproduce:
1.reboot machine with 2 interfaces
2.check which name is which interface
3.goto 1
  
Actual results:
Interface names change after reboot

Expected results:
eth0 should be wired
eth1 wireless

Additional info: 
As workaround, I added the following as first line in modprobe.conf:
 install ipw2100 /sbin/modprobe via-rhine; /sbin/modprobe --ignore-install ipw2100
This seems to fix it, but Fedora default configuration
should take care of it.
Comment 1 Harald Hoyer 2006-04-24 02:53:13 EDT
just bind the MAC Address to the interface name via system-config-network or in
the ifcfg-<interface> config file with "HWADDR=".
Comment 2 Stefan Behrens 2006-04-25 10:37:21 EDT
HWADDR= doesn't fix it. I tried again with the config below and it
still gives me the wrong results:

--ifcfg-eth0--
# VIA Technologies|VT6105 [Rhine-III]
DEVICE=eth0
HWADDR=00:40:D0:3D:7F:D5
ONBOOT=no
TYPE=Ethernet
USERCTL=yes
IPADDR=192.168.0.3
NETMASK=255.255.255.0

--ifcfg-eth1--
# Intel Corp.|PRO/Wireless LAN 2100 3B Mini PCI Adapter
DEVICE=eth1
HWADDR=00:04:23:64:85:A0
ONBOOT=no
BOOTPROTO=dhcp
TYPE=Wireless
USERCTL=yes

--modprobe.conf--
#options pbe5 radio=0
#install ipw2100 /sbin/modprobe via-rhine;/sbin/modprobe pbe5;/sbin/modprobe
--ignore-install ipw2100
alias eth0 via-rhine
alias eth1 ipw2100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0

ifconfig -a after reboot; note the swapped MACs and i/f names:

eth0      Link encap:Ethernet  HWaddr 00:04:23:64:85:A0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0x8000 Memory:e0001000-e0001fff

eth1      Link encap:Ethernet  HWaddr 00:40:D0:3D:7F:D5
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xe800

# iwlist eth1 scan
eth1      Interface doesn't support scanning.

# iwlist eth0 scan
eth0      Scan completed :
          Cell 01 - ....

Comment 3 Warren Togami 2006-04-25 11:00:46 EDT

*** This bug has been marked as a duplicate of 187550 ***

Note You need to log in before you can comment on or make changes to this bug.