Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1884569 - Normal user can't create job from exist cronjob
Summary: Normal user can't create job from exist cronjob
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1884580
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-02 10:30 UTC by Maciej Szulik
Modified: 2020-11-11 04:57 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1835066
Environment:
Last Closed: 2020-11-11 04:56:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes-kubectl pull 34 0 None closed Bug 1884569: Set appropriate owner references when creating a job from cronjob 2021-01-14 10:19:45 UTC
Github openshift oc pull 601 0 None closed [release-4.4] Bug 1884569: Set appropriate owner references when creating a job from cronjob 2021-01-14 10:19:45 UTC
Red Hat Product Errata RHBA-2020:4321 0 None None None 2020-11-11 04:57:01 UTC

Comment 3 Maciej Szulik 2020-10-23 10:28:58 UTC
This is waiting for 4.5 to be verified and only then will be allowed to merge to 4.4

Comment 5 zhou ying 2020-10-29 01:36:25 UTC
Confirmed with latest oc client, can't reproduce the issue now:

[root@dhcp-140-138 ~]# oc version 
Client Version: 4.4.0-202010281908.p0-6be9503
Kubernetes Version: v1.19.0+e67f5dc


[root@dhcp-140-138 ~]# oc create cronjob my-job --image=openshift/hello-openshift --schedule=\*\ 5\ \*\ \*\ \?
cronjob.batch/my-job created
[root@dhcp-140-138 ~]# oc create job hello-job --from=cronjob/my-job
job.batch/hello-job created

[root@dhcp-140-138 ~]# oc get job
NAME        COMPLETIONS   DURATION   AGE
hello-job   0/1           21s        21s

Comment 8 errata-xmlrpc 2020-11-11 04:56:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.30 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4321


Note You need to log in before you can comment on or make changes to this bug.