Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1884577 - gdb leaks ignored SIGPIPE to child process
Summary: gdb leaks ignored SIGPIPE to child process
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gdb
Version: DTS 10.0 RHEL 7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Keith Seitz
QA Contact: Martin Cermak
URL:
Whiteboard:
: 1884578 (view as bug list)
Depends On:
Blocks: 1888340
TreeView+ depends on / blocked
 
Reported: 2020-10-02 11:16 UTC by Michal Kolar
Modified: 2020-12-01 12:16 UTC (History)
8 users (show)

Fixed In Version: devtoolset-10-gdb-9.2-8.el7
Doc Type: No Doc Update
Doc Text:
Clone Of: 1473411
: 1888340 (view as bug list)
Environment:
Last Closed: 2020-12-01 12:15:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 2 David Smith 2020-10-06 19:06:29 UTC
Since these bugs were filed against the DTS 10.0 version of GDB, I'm setting the rhdts-10.0.0? flag.

Comment 3 Michal Kolar 2020-10-07 08:28:00 UTC
*** Bug 1884578 has been marked as a duplicate of this bug. ***

Comment 6 Frank Ch. Eigler 2020-10-22 14:32:51 UTC
It may be worth considering changing gdb itself that when forking the child process to debug, it methodically clean up -all- incoming state, including env vars, open fds, and yeah signal handlers.  It's conceivable that such litter may come in from other incidental bits of gdb environment (extension python solibs?), that a more formal hygiene pass now could prevent.

Comment 10 Martin Cermak 2020-10-26 17:40:41 UTC
Verified against devtoolset-10-gdb-9.2-8.el7 thusly:

I took the srpm, did rpmbuild -bc and then, in the testsuite dir, I did:
make check RUNTESTFLAGS='GDB=\"/opt/rh/devtoolset-10/root/usr/bin/gdb\"' TESTS=gdb.base/signals-state-child.exp

devtoolset-10-gdb-9.2-8.el7 was built using devtoolset-10-elfutils-debuginfod-client-devel-0.180-3.el7.


Reproduced and verified also with attached /tools/gdb/Regression/bz1473411-gdb-leaks-ignored-SIGPIPE-to-child-process.

Comment 12 errata-xmlrpc 2020-12-01 12:15:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (new packages: devtoolset-10-gdb), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:5295


Note You need to log in before you can comment on or make changes to this bug.