Bug 1884595 - Virtual Machine -> Network Interfaces fails with "t is undefined"
Summary: Virtual Machine -> Network Interfaces fails with "t is undefined"
Keywords:
Status: CLOSED DUPLICATE of bug 1879898
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.7.0
Assignee: Tomas Jelinek
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-02 11:53 UTC by Petr Horáček
Modified: 2020-10-02 13:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-02 13:48:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Horáček 2020-10-02 11:53:09 UTC
Description of problem:
Virtual Machine Network Interfaces view crashes when VM uses multiple interfaces.


Version-Release number of selected component (if applicable):
CNV 2.5 stage
Client Version: 4.6.0-fc.7
Server Version: 4.6.0-fc.7
Kubernetes Version: v1.19.0+b4ffb45


How reproducible:


Steps to Reproduce:
1. Create NAD

cat <<EOF | oc create -f -
apiVersion: "k8s.cni.cncf.io/v1"
kind: NetworkAttachmentDefinition
metadata:
  name: br10
spec:
  config: '{
      "cniVersion": "0.3.1",
      "type": "bridge",
      "bridge": "br10"
    }'
EOF


2. Create a VM using it

cat <<EOF | oc create -f -
---
apiVersion: kubevirt.io/v1alpha3
kind: VirtualMachineInstance
metadata:
  labels:
    special: vmi1
  name: vmi1
spec:
  domain:
    devices:
      disks:
      - disk:
          bus: virtio
        name: containerdisk
      - disk:
          bus: virtio
        name: cloudinitdisk
      interfaces:
      - masquerade: {}
        name: default
      - bridge: {}
        name: br10
    machine:
      type: ""
    resources:
      requests:
        memory: 1024M
  networks:
  - name: default
    pod: {}
  - name: br10
    multus:
      networkName: br10
  volumes:
  - containerDisk:
      image: kubevirt/fedora-cloud-container-disk-demo
    name: containerdisk
  - cloudInitNoCloud:
      networkData: |
        version: 2
        ethernets:
          eth1:
            addresses: [ 192.168.111.10/24 ]
      userData: |-
        #!/bin/bash
        echo "fedora" |passwd fedora --stdin
    name: cloudinitdisk
EOF


3. Open Virtual Machine details, Network Interfaces

Actual results:
Shows details

Expected results:
Fails with

TypeError

Description:

t is undefined

Component Trace:

in S
    in t
    in t
    in div
    in Data
    in StatusBox
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown
    in O
    in Unknown
    in O
    in Unknown
    in o
    in DetailsPage
    in E
    in l
    in t
    in C
    in t
    in div
    in div
    in section
    in PageSection
    in Unknown
    in O
    in div
    in div
    in DrawerMain
    in DrawerContent
    in div
    in Drawer
    in NotificationDrawer
    in Unknown
    in O
    in main
    in div
    in Page
    in div
    in DrawerContentBody
    in div
    in div
    in DrawerMain
    in DrawerContent
    in div
    in Drawer
    in Unknown
    in O
    in I
    in I
    in l
    in O
    in Unknown
    in O
    in t
    in t
    in t
    in t

Stack Trace:

S@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/kubevirt~kubevirt-create-vm-wizard-chunk-95b9155c3023a44ae464.min.js:1:85497
No@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:55337
Ks@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:98261
Bs@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:84010
Fs@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:81035
Ms@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:79608
hi/<@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:41759
t.unstable_runWithPriority@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:168:3878
li@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:41488
hi@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:41707
di@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:41640
Rs@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:80035
Rn/r<@https://console-openshift-console.apps.ostest.zeus15.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-c9c80453d4b86c3e1520.min.js:160:31169

Additional info:

Comment 1 Tomas Jelinek 2020-10-02 13:48:59 UTC

*** This bug has been marked as a duplicate of bug 1879898 ***


Note You need to log in before you can comment on or make changes to this bug.