Bug 1884598 - Review Request: clitest - Command Line Tester
Summary: Review Request: clitest - Command Line Tester
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonny Heggheim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-02 12:11 UTC by Jonny Heggheim
Modified: 2020-10-05 17:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-05 17:46:08 UTC
Type: ---
andymenderunix: fedora-review+


Attachments (Terms of Use)

Description Jonny Heggheim 2020-10-02 12:11:14 UTC
Spec URL: https://jonny.fedorapeople.org//clitest.spec
SRPM URL: https://jonny.fedorapeople.org//clitest-0.4.0-1.fc32.src.rpm

Description:
clitest is a portable POSIX shell script that performs automatic testing in \
Unix command lines.

It's the same concept as in Python's doctest module: you document both the \
commands and their expected output, using the familiar interactive prompt \
format, and a specialized tool tests them.

Comment 1 Jonny Heggheim 2020-10-02 12:11:19 UTC
This package built on koji:  https://koji.fedoraproject.org/koji/taskinfo?taskID=52647350

Comment 2 Andy Mender 2020-10-03 15:37:03 UTC
I see fedora-review struggled with resolving %{forgesource}, but since it worked in Koji, everything's in order. 

Package approved. Full review below:

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[ ]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
     Note: Using prebuilt packages
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "Expat License". 77 files have unknown
     license. Detailed output of licensecheck in
     /home/amender/rpmbuild/SPECS/clitest/clitest/licensecheck.txt
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[!]: Sources can be downloaded from URI in Source: tag
     Note: Could not download Source0:
     https://github.com/aureliojargas/clitest/archive/v0.4.0/clitest-0.4.0.tar.gz
     See: https://docs.fedoraproject.org/en-US/packaging-
     guidelines/SourceURL/
     Review: Indeed, the above link returns HTTP 404, however the below path works:
     https://github.com/aureliojargas/clitest/archive/0.4.0.tar.gz
     Does %{forgesource} get incorrectly generated? It works in Koji, though...
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[-]: Sources are verified with gpgverify first in %prep if upstream
     publishes signatures.
     Note: gpgverify is not used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.


Rpmlint
-------
Checking: clitest-0.4.0-1.fc34.noarch.rpm
          clitest-0.4.0-1.fc34.src.rpm
clitest.noarch: W: spelling-error %description -l en_US doctest -> doc test, doc-test, doctorate
clitest.noarch: W: no-manual-page-for-binary clitest
clitest.src: W: spelling-error %description -l en_US doctest -> doc test, doc-test, doctorate
clitest.src: W: invalid-url Source0: https://github.com/aureliojargas/clitest/archive/v0.4.0/clitest-0.4.0.tar.gz HTTP Error 404: Not Found
2 packages and 0 specfiles checked; 0 errors, 4 warnings.




Rpmlint (installed packages)
----------------------------
(none): E: no installed packages by name clitest
0 packages and 0 specfiles checked; 0 errors, 0 warnings.



Requires
--------
clitest (rpmlib, GLIBC filtered):
    /usr/bin/sh



Provides
--------
clitest:
    clitest

Comment 3 Jonny Heggheim 2020-10-04 11:01:38 UTC
(In reply to Andy Mender from comment #2)
> I see fedora-review struggled with resolving %{forgesource}, but since it
> worked in Koji, everything's in order. 
> 
> Package approved. Full review below:

Thanks for the review.

fedora-review spotted an actual problem in %{forgesource}, thanks for pointing it out, it probably saved me a lot of debugging. %forge-macro assume that git-tags/releases have 'v' as a prefix, clitest used nothing as prefix.

So adding
> %global tag %{version}
solved the sourceurl

Comment 4 Gwyn Ciesla 2020-10-05 13:28:08 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/clitest


Note You need to log in before you can comment on or make changes to this bug.