Bug 188481 - docbook2X fails to build because of missing perl-XML-SAX dependency
docbook2X fails to build because of missing perl-XML-SAX dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docbook2X (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-10 11:12 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8.6-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 13:49:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix docbook2X spec file (414 bytes, patch)
2006-04-10 11:12 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-04-10 11:12:17 EDT
Description of problem: 
 
docbook2X RPM fails to build because of a missing Requires: perl-XML-SAX line. 
 
Version-Release number of selected component (if applicable): 
 
docbook2X-0.8.5-2.fc5.src.rpm 
 
How reproducible: 100% 
 
 
Steps to Reproduce: 
1. rpmbuild --rebuild source rpm or rpmbuild -bb spec file 
 
   
Actual results: 
 
RPM fails to build. 
 
Expected results: 
 
RPM should build.
Comment 1 Prarit Bhargava 2006-04-10 11:12:18 EDT
Created attachment 127550 [details]
Patch to fix docbook2X spec file
Comment 2 Patrice Dumas 2006-04-10 13:13:12 EDT
Ok. From my investigation, it looks like it comes from the perl -c call. I'll
apply it soon, but since there is a new release, I'll update at the same time.
Comment 3 Patrice Dumas 2006-04-10 13:14:19 EDT
Shouldn't it be a BuildRequires instead of a Requires?
Comment 4 Prarit Bhargava 2006-04-10 13:15:32 EDT
>Shouldn't it be a BuildRequires instead of a Requires? 
 
:) Yep, you're right.  My bad. 
 
P. 
Comment 5 Patrice Dumas 2006-04-10 13:49:54 EDT
Fixed in 0.8.6-1.fc6

Note You need to log in before you can comment on or make changes to this bug.