Bug 188484 - gnome-sudoku fails to build because of rpm spec file errors
gnome-sudoku fails to build because of rpm spec file errors
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-sudoku (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-10 11:34 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-13 07:38:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix %if typos in gnome-sudoku rpm spec file (603 bytes, patch)
2006-04-10 11:34 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-04-10 11:34:04 EDT
Description of problem:  
  
gnome-sudoku fails to build because of rpm spec file errors.  There are two  
issues, the first is incorrect %if statements, and the second is a missing  
patch.  
  
Version-Release number of selected component (if applicable):  
  
gnome-sudoku-0.4.0-5.fc5.src.rpm  
  
How reproducible: 100%  
  
  
Steps to Reproduce:  
1. rpmbuild --rebuild source RPM or rpmbuild -bb spec.file  
    
Actual results: RPM fails to build  
  
  
Expected results: RPM should build  
 
Additional info: A patch to fix the %if statements is in this BZ, however, I 
do not have CVS access to fix the issue with the missing .patch file ...
Comment 1 Prarit Bhargava 2006-04-10 11:34:05 EDT
Created attachment 127552 [details]
Patch to fix %if typos in gnome-sudoku rpm spec file
Comment 2 Paul Howarth 2006-04-10 12:05:17 EDT
The patch is missing because you've picked up an FC5/rawhide version of the SRPM,
which doesn't include the patch since it isn't needed there.

The SRPM would be more portable if it included the patch file in the SRPM
unconditionally and just used the %{fedora} macro to decide whether or not to
apply the patch.
Comment 3 Prarit Bhargava 2006-04-10 13:11:34 EDT
>The patch is missing because you've picked up an FC5/rawhide version of the  
SRPM,  
which doesn't include the patch since it isn't needed there.  
  
Ok, but I'm building on a system with   
  
[root@altix2 SPECS]# rpm -q fedora-release  
fedora-release-5.89-rawhide  
  
Is there another RPM package I need to update such that  
%{fedora} resolves correctly?  
  
>The SRPM would be more portable if it included the patch file in the SRPM 
unconditionally and just used the %{fedora} macro to decide whether or not to 
apply the patch. 
  
IMO, that's probably a better way to do it ... 
 
P. 

Note You need to log in before you can comment on or make changes to this bug.