This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188501 - Cronjobs from /etc/cron.d does not run
Cronjobs from /etc/cron.d does not run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 13:47 EDT by Lars Berntzon
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-12 16:22:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lars Berntzon 2006-04-10 13:47:43 EDT
Description of problem:

Cron does not run jobs in the directory /etc/cron.d

Version-Release number of selected component (if applicable):

This happens for both FC3 and FC4.

How reproducible:

Always

Steps to Reproduce:
1. Create a crontab style file in /etc/cron.d. Make it only writeable by owner
root and not executable.
2. Set the time for the job a couple of minutes in the future
3. Look at the /var/log/cron file. 
  
Actual results:

Cron does notice that the file is changed, my log looks like this:
Apr 10 19:32:01 xella35 crond[2369]: (*system*) RELOAD (/etc/cron.d/rsync-backup)

But then nothing more happens.


Expected results:

The job should be started.

Additional info:
Comment 1 Lars Berntzon 2006-04-10 14:12:08 EDT
Aha, just found it. Files in the /etc/cron.d has to have an extra field for
which user to run as. So the format should be
<min> <hour> <day> <mon> <weekday> <user> <command> ...

So this is really a documentation bug.
Comment 2 Jason Vas Dias 2006-04-12 16:22:14 EDT
From 'man 5 crontab:'
'
  Each line has five time and date fields, followed by a user  name  
  if this is a system crontab  file,  followed  by a command.
'

Note You need to log in before you can comment on or make changes to this bug.