Bug 1885132 - [OVN] Run OVN tasks on host re-install flow
Summary: [OVN] Run OVN tasks on host re-install flow
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.4.3.5
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.4.4
: 4.4.4
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-05 07:47 UTC by Michael Burman
Modified: 2020-12-21 12:36 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.4.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-21 12:36:47 UTC
oVirt Team: Network
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 111668 0 master MERGED core: Drop network provider id of host 2021-01-19 16:45:47 UTC
oVirt gerrit 111670 0 master MERGED Document network provider of host as read-only 2021-01-19 16:45:47 UTC
oVirt gerrit 111997 0 master MERGED restapi: network provider of host as read-only 2021-01-19 16:45:47 UTC
oVirt gerrit 111998 0 master MERGED core: Use the network provider of the cluster for hosts 2021-01-19 16:45:47 UTC
oVirt gerrit 111999 0 master MERGED provider: use hostname as fallback for host binding id 2021-01-19 16:45:47 UTC

Description Michael Burman 2020-10-05 07:47:28 UTC
Description of problem:
[OVN] Run OVN tasks on host re-install flow

The OVN tasks are not executed as they should during the host re-install flow.
I'm pretty sure this is a regression, i know this area of code was otuched lately.

When performing a host re-install the OVN tasks doesn't triggered during the ansible deploy as they should.

Version-Release number of selected component (if applicable):
rhvm-4.4.3.5-0.5.el8ev.noarch
ovirt-ansible-roles-1.2.3-1.el8ev.noarch
ansible-runner-service-1.0.6-2.el8ev.noarch
ansible-runner-1.4.5-1.el8ar.noarch
ansible-2.9.13-1.el8ae.noarch

How reproducible:
100%

Steps to Reproduce:
1. Add fresh host to a cluster with OVN as network default provider
2. Set host to maintenance
3. Do re-install

Actual results:
1. OVN tasks run as expected and OVN configured
3. OVN tasks doesn't triggered and OVN wasn't configured

Expected results:
3. OVN tasks should be triggered on host re-install as well

Additional info:
I'm pretty sure this is a regression.

Comment 2 Dominik Holler 2020-10-06 16:02:30 UTC
Looks like the association of the host to the network provider is lost sometimes:

engine=# select vds_name,openstack_network_provider_id from vds_static;
   vds_name   |    openstack_network_provider_id     
--------------+--------------------------------------
 host_mixed_1 | 
 host_mixed_2 | a0ee5275-cd53-4884-848c-2a3e2cfe504c
 host_mixed_3 | 

This is an inconsistency in the db, because the network provider is managed completely on cluster level.
One way to fix the bug would be to find the flow which created the inconsistency.
Alternatively we could think about replacing the openstack_network_provider_id column by a reference to the network provider of the cluster and remove all code which writes to this column.

Comment 3 Sandro Bonazzola 2020-11-06 13:46:25 UTC
Can be tested with 4.4.3.

Comment 7 Dominik Holler 2020-11-09 07:53:31 UTC
Sorry for the confusion, the fix is ovirt-engine-4.4.4 only.

Comment 8 Michael Burman 2020-11-15 10:17:28 UTC
Verified on - rhvm-4.4.4-0.1.el8ev.noarch

Comment 9 Sandro Bonazzola 2020-12-21 12:36:47 UTC
This bugzilla is included in oVirt 4.4.4 release, published on December 21st 2020.

Since the problem described in this bug report should be resolved in oVirt 4.4.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.