This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188516 - enchant rpm fails to build due to unpackaged file
enchant rpm fails to build due to unpackaged file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: enchant (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-10 16:12 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 17:20:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix for unpackaged files in enchant spec file (263 bytes, patch)
2006-04-10 16:12 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-04-10 16:12:16 EDT
Description of problem:

enchant rpm fails to build due to unpackaged file.

Version-Release number of selected component (if applicable):
enchant-1.2.2-2.fc5.src.rpm

How reproducible: 100%


Steps to Reproduce:
1. rpmbuild --rebuild source rpm or rpmbuild -bb spec.file
  
Actual results:

build fails.

Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/enchant-1.2.2-root
error: Installed (but unpackaged) file(s) found:
   /usr/share/enchant/enchant.ordering


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/share/enchant/enchant.ordering

Expected results:

Build should succeed.

Additional info: Patch attached.  I'm assuming that we don't want to simply
exclude all unpackaged file errors ...
Comment 1 Prarit Bhargava 2006-04-10 16:12:16 EDT
Created attachment 127571 [details]
Fix for unpackaged files in enchant spec file
Comment 2 Marc Maurer 2006-04-10 17:20:55 EDT
Thanks, fixed using an equivalent patch

Note You need to log in before you can comment on or make changes to this bug.