Bug 188531 - yum-utils rpm does not build due to unpackaged files error
yum-utils rpm does not build due to unpackaged files error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-10 17:51 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 06:01:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix unpackaged files warning in yum-utils spec file (599 bytes, patch)
2006-04-10 17:51 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-04-10 17:51:18 EDT
Description of problem:

yum-utils does not build due to unpackaged files being present
Version-Release number of selected component (if applicable):
yum-utils-0.5-1.src.rpm

How reproducible: 100%

Steps to Reproduce:
1. rpmbuild --rebuild source rpm or rpmbuild -bb spec.file
 
Actual results:

Build fails with:

Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/yum-utils-0.5-1-root-root
error: Installed (but unpackaged) file(s) found:
   /usr/lib/yum-plugins/changelog.pyc
   /usr/lib/yum-plugins/changelog.pyo
   /usr/lib/yum-plugins/fastestmirror.pyc
   /usr/lib/yum-plugins/fastestmirror.pyo


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib/yum-plugins/changelog.pyc
   /usr/lib/yum-plugins/changelog.pyo
   /usr/lib/yum-plugins/fastestmirror.pyc
   /usr/lib/yum-plugins/fastestmirror.pyo

Expected results:

rpm build should complete.

Additional info: Patch attached.
Comment 1 Prarit Bhargava 2006-04-10 17:51:19 EDT
Created attachment 127577 [details]
Patch to fix unpackaged files warning in yum-utils spec file
Comment 2 Tim Lauridsen 2007-02-14 06:01:03 EST
This is fixed in the current yum-utils 1.0.x releases.

Note You need to log in before you can comment on or make changes to this bug.