Bug 188537 - Amarok hangs playing streams
Amarok hangs playing streams
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 18:54 EDT by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 08:17:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2006-04-10 18:54:26 EDT
Description of problem:


Version-Release number of selected component (if applicable):
amarok-1.4-0.9.beta2.fc5


How reproducible:
always


Steps to Reproduce:
1.run amarok http://oggtrial.nm.cbc.ca:80/cbcr1-toronto.ogg
2.
3.
  
Actual results:
amarok hangs


Expected results:
play the stream


Additional info:
xmms plays this stream fine.  It also fails for mp3 streams with the
gstreamer-ugly plugin.

The only output from amarok on the console is:
(<unknown>:8015): GStreamer-CRITICAL **: gst_element_link_pads_filtered:
assertion `GST_IS_ELEMENT (src)' failed
Comment 1 Aurelien Bompard 2006-04-11 02:39:40 EDT
The Amarok devs say that it's a bug in gstreamer 0.10. Please try with a
different  engine, for example Helix. That should work (at least it worked for me)
Comment 2 Brian G. Anderson 2006-04-11 08:15:38 EDT
I switched to Helix and it worked for me for the ogg stream.  Of course, I can't
use Helix for mp3 streams as there doesn't seem to be an mp3 plugin for the
Helix engine.

Should this bug be moved to gstreamer?  I did a query and there is no such bug
against gstreamer or any of its plugins.
Comment 3 Aurelien Bompard 2007-01-11 08:17:54 EST
The gstreamer engine has been known to have problem with remote streams. Please
stick to the Helix engine or use the new xine engine.

Note You need to log in before you can comment on or make changes to this bug.