Bug 188547 - Fan does not operate on AMD Turion 64
Fan does not operate on AMD Turion 64
Status: CLOSED DUPLICATE of bug 188546
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 21:29 EDT by Peter Barker
Modified: 2015-03-04 20:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 01:56:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compressed log, DSDT and lspci output (36.94 KB, application/octet-stream)
2006-04-10 21:29 EDT, Peter Barker
no flags Details

  None (edit)
Description Peter Barker 2006-04-10 21:29:08 EDT
Description of problem:
Fan speed control does not work unless read /proc/acpi/Thermal_zone/TZ1/
temperature
System may hang for a few seconds after issuing command to read this file. acpid 
usage may go to 99% for a few minutes.
I think fan comes on at lower temperatures in Windows XP on this PC.

Version-Release number of selected component (if applicable):
Kernel 2.6.16-1.2080_FC5 for x86_64 
acpid 1.0.4-2

How reproducible:
Always?

Steps to Reproduce:
1. Run a CPU-intensive program
2. Wait for CPU to heat up (above 60 deg?)
3. cat /proc/acpi/therm*/*/temperature - fan will start
4. Wait for CPU to cool down (to 50 deg)
5. cat /proc/acpi/therm*/*/temperature - fan will stop
  
Actual results:
Fan stops/starts only when access file

Expected results:
Should stop/start without file access.

Additional info:
Have noticed the default FC5 x86_64 installation DVD installs both i386 and 
x86_64 versions of many packages (eg hal-0.5.7-3

Have attached a decompiled DSDT, lspci output, and messages log

cpuinfo:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 36
model name      : AMD Turion(tm) 64 Mobile ML-40
stepping        : 2
cpu MHz         : 800.000
cache size      : 1024 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov 
pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow 
pni lahf_lm
bogomips        : 1599.43
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc
Comment 1 Peter Barker 2006-04-10 21:29:08 EDT
Created attachment 127584 [details]
compressed log, DSDT and lspci output
Comment 2 John Thacker 2006-04-19 01:56:29 EDT
Looks like two identical bugs were created by mistake.  Closing the duplicate.

*** This bug has been marked as a duplicate of 188546 ***

Note You need to log in before you can comment on or make changes to this bug.