Bug 1885535 - NodeSelector is not visible on the OLM auto generated form for HCO CR
Summary: NodeSelector is not visible on the OLM auto generated form for HCO CR
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.7.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-06 10:11 UTC by Simone Tiraboschi
Modified: 2021-01-05 17:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-05 17:36:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
OLM auto generated form (223.96 KB, image/png)
2020-10-06 10:11 UTC, Simone Tiraboschi
no flags Details
OLM form with PR #864 (289.85 KB, image/png)
2020-10-07 14:07 UTC, Simone Tiraboschi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github kubevirt hyperconverged-cluster-operator pull 864 0 None closed Add Operator Descriptors to properly render node placement on UI 2021-01-05 17:37:07 UTC

Description Simone Tiraboschi 2020-10-06 10:11:01 UTC
Description of problem:
NodeSelector is not visible on the OLM auto generated form for HCO CR,
see the attached screenshot.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. check the form to create a new CR for HCO on OCP 4.6
2.
3.

Actual results:
NodeSelector is not visible

Expected results:
NodeSelector is visible

Additional info:
spec.version is also visible why it should be hidden

Comment 1 Simone Tiraboschi 2020-10-06 10:11:31 UTC
Created attachment 1719322 [details]
OLM auto generated form

Comment 2 Fabian Deutsch 2020-10-06 12:06:45 UTC
Simone, despite that the field is not visible in the UI; Can the field be set in the yaml, and will it be recognized?

Comment 3 Simone Tiraboschi 2020-10-06 13:03:43 UTC
Yes, it works as expected when the user directly patches the CR but it it's not rendered as expected in the UI nor explained by `oc explain`.

I tend to think we a kubebuilder annotation somewhere.

Comment 5 Simone Tiraboschi 2020-10-07 09:08:51 UTC
Let's try to get in fixed in 2.5.0 or 2.5.z at worst.

Comment 6 Simone Tiraboschi 2020-10-07 14:06:55 UTC
With https://github.com/kubevirt/hyperconverged-cluster-operator/pull/864 we can get something nicer on the UI because:
- it's using a nicer widget for affinity
- infra and workloads are one after the other
- spec.version is not visible

(see the new screenshots)

Unfortunately NodeSelector is still not visible.

Comment 7 Simone Tiraboschi 2020-10-07 14:07:22 UTC
Created attachment 1719766 [details]
OLM form with PR #864

Comment 8 Inbar Rose 2020-12-02 13:39:01 UTC
This is a UI issue only

Comment 9 Tomas Jelinek 2020-12-03 08:56:55 UTC
We dont have any custom UI code in the OLM screens, moving to the core

Comment 10 Jon Jackson 2020-12-04 22:27:02 UTC
Looked into this. We currently don't support generation of form fields for object schema's with only "additionalProperties" defined. This was an intentional exclusion when scoping the original form generation story. Adding support for this would not be trivial and would require some design consideration.

Comment 11 Jon Jackson 2021-01-05 17:36:23 UTC
Closing as this is working as expected. This needs to be handled as an RFE as it will require adding a new feature.


Note You need to log in before you can comment on or make changes to this bug.