Bug 188562 - getaddrinfo() fails if nsswitch.conf contains 'files nisplus dns'
Summary: getaddrinfo() fails if nsswitch.conf contains 'files nisplus dns'
Status: CLOSED DUPLICATE of bug 186592
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-11 09:17 UTC by Avi Kivity
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 09:23:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Avi Kivity 2006-04-11 09:17:50 UTC
Description of problem: 
 
rsync uses getaddrinfo to determine the ip of the remote host name. 
if /etc/nsswitch.conf contains the line 
 
    hosts: files nisplus dns 
 
then rsync will fail in getaddrinfo(). other programs (host, ping) succeed. 
 
Version-Release number of selected component (if applicable): 
 
glibc-2.4-4 
 
How reproducible: 
 
always, but a test program does not manage to reproduce. 
 
 
Steps to Reproduce: 
1. sed -i 's/^hosts.*/hosts: files nisplus dns' /etc/nsswitch.conf 
2. rsync distro.ibiblio.org:: 
 
   
Actual results: 
 
rsync complains 
 
Expected results: 
 
rsync lists hosts 
 
Additional info: 
 
some debugging showed that the hosts line is mis-parsed, but I'm not sure. 
strace -e trace=open shows that the dns module is never loaded. 
 
the problem occurs on i386 and x86_64.

Comment 1 Jakub Jelinek 2006-04-11 09:23:33 UTC

*** This bug has been marked as a duplicate of 186592 ***


Note You need to log in before you can comment on or make changes to this bug.