Bug 18857 - GnoSamba Help Fails
Summary: GnoSamba Help Fails
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: GnoSamba   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-10 22:09 UTC by Bob Rose
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 14:06:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob Rose 2000-10-10 22:09:25 UTC
Any attempt to use Help inside GnoSamba generates an error message "Cannot 
open man page.  Verify you have it installed and in your MANPATH".  

With no MANPATH defined, the console window from which I launched GnoSamba 
indicates that the program is looking for man pages in "/usr/man/man5" 
and "/usr/local/man/man5".  Since the man pages moved to "/usr/share/man" 
in the 7.0 RedHat release, perhaps this program's rpm should be rebuilt to 
look for its man pages in the new location.

As info, setting MANPATH to "/usr/share/man" does allow the program to 
operate normally.  However, having to set MANPATH to a value included in 
the default man path used by every other app would seem to me to be bad 
policy...

Comment 1 Tim Powers 2000-10-16 13:20:14 UTC
Can you please try out this package: 
http://people.redhat.com/timp/RPMS/GnoSamba-0.3.3-11.i386.rpm

It's patched with the default /usr/share/man path included.

Please let me know how it goes, either way.

Tim

Comment 2 Bob Rose 2000-10-16 13:44:36 UTC
Got the new RPM and installed it.  'Help' works as expected.  There were four  
additional console messages of the form '<standard input>:5460: warning: 
numeric expression expected (got 's')'.  The other three were the same message 
with numbers 5526, 5550, and 5579 against "/usr/share/man/man5/smb.conf.gz".  
Help did display the requested info.  Perhaps just a formatting issue?

  


Comment 3 Tim Powers 2000-10-16 13:59:33 UTC
I think that it's expected behaviour. If you test it like I did (cp
/usr/share/man/man5 to /usr/man/man5) and run the old client the same output on
the console is given, and the same happens when MANPATH is set to
/usr/share/man.

I am resolving this to "rawhide" for right now. I will release an errata for
this once it gets through the QA process, ance that's done it will be resolved
to "errata".

Tim

Comment 4 Bob Rose 2000-10-16 14:06:01 UTC
Thanks, and "case closed."



Note You need to log in before you can comment on or make changes to this bug.