Bug 188576 - Doesn't follow Xt's size hints
Doesn't follow Xt's size hints
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 09:00 EDT by Bastien Nocera
Modified: 2014-06-18 05:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 16:02:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
max_test.c (653 bytes, text/plain)
2006-04-11 09:00 EDT, Bastien Nocera
no flags Details
metacity log for RHEL4 (250.86 KB, text/plain)
2006-04-11 09:02 EDT, Bastien Nocera
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 327543 None None None Never

  None (edit)
Description Bastien Nocera 2006-04-11 09:00:31 EDT
Also upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=338073

1. Compile and launch the attached testcase
2. Maximise the window:
- metacity 2.8.6-2.8 (the current RHEL4) resizes to the full width and height of
the desktop
- metacity 2.14.0-1 (current FC5) doesn't resize the window at all and shows it
"maximised"
- WindowMaker, icewm and Blackbox work as expected (maximised state, 500x500 in
size).
Comment 1 Bastien Nocera 2006-04-11 09:00:32 EDT
Created attachment 127611 [details]
max_test.c
Comment 2 Bastien Nocera 2006-04-11 09:02:35 EDT
Created attachment 127613 [details]
metacity log for RHEL4
Comment 3 Søren Sandmann Pedersen 2006-04-11 12:16:52 EDT
The RHEL 4 behavior is as it is by design, but the FC5 behavior is pretty
clearly a bug.
Comment 4 Bastien Nocera 2006-04-12 07:06:50 EDT
Reassigning to Fedora to keep track of the upstream bug.
Comment 5 Søren Sandmann Pedersen 2006-09-06 16:02:03 EDT
Upstream claims to have fixed this.

Note You need to log in before you can comment on or make changes to this bug.