Bug 1885792 - f33.png symlink broken in 33.0.6, results in no background on KDE and maybe other desktops
Summary: f33.png symlink broken in 33.0.6, results in no background on KDE and maybe o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: f33-backgrounds
Version: 33
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedBlocker
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-10-06 22:28 UTC by Adam Williamson
Modified: 2020-10-07 22:58 UTC (History)
2 users (show)

Fixed In Version: f33-backgrounds-33.0.7-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-07 22:58:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2020-10-06 22:28:20 UTC
There's a bug in f33-backgrounds-33.0.6-1.fc33 . /usr/share/backgrounds/f33/default/f33.png is a symlink, and it's broken:

[root@xps13k tmp]# ls /usr/share/backgrounds/f33/default/f33.png -l
lrwxrwxrwx. 1 root root 24 Oct  5 18:33 /usr/share/backgrounds/f33/default/f33.png -> ./default/f33-02-day.png

note that the target is ./default/f33-02-day.png , with a single period. It's supposed to be ../default/f33-02-day.png , with two periods.

The symlink is created by a Makefile, and the problem is a stray dollar sign. The offending commit is this one:

https://github.com/fedoradesign/backgrounds/commit/1d5915fc77eb217ca59fdc2d1a6fc4c7b813b18c

Luya made the same change on both master branch and f33-backgrounds branch. On master branch it was done right, but on f33-backgrounds branch he left the dollar sign in accidentally, so the line reads:

$(LN_S) $../default/$(WP_NAME)-02-day.png	$(WP_DIR)/default/$(WP_NAME).png

what that actually *runs* during the package build is:

/bin/ln -s ./default/f33-02-day.png	/builddir/build/BUILDROOT/f33-backgrounds-33.0.6-1.fc33.noarch/usr/share/backgrounds/f33/default/f33.png

..and so the symlink winds up broken. The fix is simply to drop the dollar sign. I'll send a PR.

This is a clear Final blocker because it means the background on KDE (a release blocking desktop) is a black screen. It doesn't quite hit the automatic blocker rules, though, so I'm just proposing it as a blocker per Final criterion "The proposed final Fedora artwork must be included and used as the background on release-blocking desktops".

Comment 1 Adam Williamson 2020-10-06 23:10:21 UTC
https://github.com/fedoradesign/backgrounds/pull/27

Comment 2 Fedora Update System 2020-10-07 01:28:33 UTC
FEDORA-2020-27f80050a2 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-27f80050a2

Comment 3 Adam Williamson 2020-10-07 19:20:01 UTC
+3 votes in https://pagure.io/fedora-qa/blocker-review/issue/144 , setting accepted.

Comment 4 Fedora Update System 2020-10-07 22:58:23 UTC
FEDORA-2020-27f80050a2 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.