Bug 188580 - anaconda clearpart command no longer deletes all partitions silently
anaconda clearpart command no longer deletes all partitions silently
Status: CLOSED DUPLICATE of bug 188579
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-04-11 10:01 EDT by Rick Kornfeld
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-05 14:26:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rick Kornfeld 2006-04-11 10:01:00 EDT
Description of problem:
In RH3 using Kick start ks.cfg you were able to use the clearpart --all --
initlabel command to silently clear,clean, delete ALL existing partitions from 
the server without user intervention. This allowed us to boot to a CD then walk 
away until the Kickstart process was over and the server rebooted.

When we started to develop RH4 using Update 3 also Kickstart and the clearpart -
-all --initlabel, we noticed that the first time the server built all the 
partitions were deleted and it worked fine, however, the second time we built 
the same server we received Python - anaconda errors at kickstart time saying 
the install could not create a LVM PV because there was no space. Upon 
rebooting we continued to get the same error. We then recreated the ks.cfg file 
and removed the --initlabel option from the clearpart statement. After 
rebooting and each additional time we re-built the server, instead of getting 
the Python error we received a nice GUI interface asking us if we would like to 
clear all the partitions off the server. When we answered yes the installation 
continued without incident. Again, each subsequent time we rebuild the same 
server the nice GUI interface came up and asked us if we wanted to delete all 
the partitions. Again, answering yes allowed the installation to proceed 
without problems. The issue is we can NO LONGER build these servers silently. A 
user must stay at the server side until they can answer yes to the delete all 
partitions GUI question. Is this a bug or are we missing some option to the 
clearpart command to allow us silent installs (user free) like we did in RH3?


Version-Release number of selected component (if applicable):
RH 4 Update 3 - This is the first version of RH 4 we used. We have no knowledge 
if the clearpart command acted any different in RH4 Update 1 or 2

How reproducible:
Each subsequent time we rebuild the same server we get the error

Steps to Reproduce:
1. Use clearpart --all --initlabel in the ks.cfg (This produces the Python 
cannot create LVM error on all rebuilds,re-installs of RH4 U3 of the same 
server AFTER the initial build)
2. Replace with clearpart --all in the ks.cfg (This produces the delete 
partitions GUI on all rebuilds,re-installs of RH4 U3 of the same server AFTER 
the initial build)

Actual results:
Python error in anaconda

Expected results:
Allow silent user free installation with ks.cfg

Additional info:
Comment 1 nathan r. hruby 2006-06-02 13:04:51 EDT
FYI: Bug 188579 is a duplicate of this bug
Comment 2 Chris Lumens 2006-06-05 14:26:01 EDT

*** This bug has been marked as a duplicate of 188579 ***

Note You need to log in before you can comment on or make changes to this bug.