Bug 188598 - openoffice fails to start
openoffice fails to start
Status: CLOSED DUPLICATE of bug 160290
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 12:34 EDT by Niall Hallett
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 12:58:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niall Hallett 2006-04-11 12:34:04 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.0.2-5.7.2

How reproducible:
always

Steps to Reproduce:
1. run oocalc, or any oo* prog
2.
3.
  
Actual results:
/usr/lib/openoffice.org2.0/program/soffice: line 151: 19356 Segmentation fault 
    "$sd_prog/$sd_binary" "$@"

Expected results:


Additional info:
Nothing appears, have to run at the console to get the above error.

Linux version 2.6.16-1.2080_FC5 (bhcompile@hs20-bc1-4.build.redhat.com) (gcc
version 4.1.0 20060304 (Red Hat 4.1.0-3)) #1 SMP Tue Mar 28 03:38:47 EST 2006

xorg-x11-drv-nvidia-1.0.8756-1.lvn5

> gdb /usr/lib/openoffice.org2.0/program/soffice.bin
(gdb) run -calc
(no debugging symbols found)
...
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 4160566960 (LWP 19717)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x00a8d2e5 in pthread_once () from /lib/libpthread.so.0
#2  0xf7c8984e in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#3  0xf7cbd478 in ?? () from /usr/lib/libGL.so.1
#4  0xf7c89bd0 in _init () from /usr/lib/libGL.so.1
#5  0xffffa944 in ?? ()
#6  0x00000000 in ?? ()
Comment 1 Caolan McNamara 2006-04-11 12:58:10 EDT
Whatever that is, it's a bug with nvidia drivers rather than OOo.

You can try and disable OOO's 3d support with 

> export SAL_NOOPENGL=true
> oowriter

Does that work around the problem ?

Alternatively try disabling selinux.

*** This bug has been marked as a duplicate of 160290 ***
Comment 2 Niall Hallett 2006-04-12 04:25:35 EDT
Yep, setting SAL_NOOPENGL=true works for me.

I never had selinux enabled.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.