Bug 1885997 - [OVS] Trigger sync while switching host from legacy type cluster to OVS type and vise versa
Summary: [OVS] Trigger sync while switching host from legacy type cluster to OVS type ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.4.3.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.4.4
: 4.4.4.2
Assignee: eraviv
QA Contact: Guy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-07 12:24 UTC by Michael Burman
Modified: 2020-12-21 12:35 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.4.4.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-21 12:35:50 UTC
oVirt Team: Network
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 112239 0 master MERGED core: sync networks on change host switch type 2020-12-21 12:53:50 UTC

Description Michael Burman 2020-10-07 12:24:38 UTC
Description of problem:
[OVS] Trigger sync while switching host from legacy type cluster to OVS type and vise versa

Now when we reviving OVS switch type cluster on rhel 8.3 hosts and nmstate, and we support the flow of moving host from legacy cluster type to OVS type and vise versa. We need to make the sync triggered automatically while performing such operations.
This will reduce the manual effort from the user/admin that might miss the need of sync ovirtmgmt network. 

Version-Release number of selected component (if applicable):
4.4.3.5-0.5.el8ev

Comment 1 Dominik Holler 2020-10-20 13:09:07 UTC
It should be ensured, that changing the cluster succeeds, even if the host is offline.

Comment 2 RHEL Program Management 2020-11-20 14:05:08 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 3 Michael Burman 2020-11-22 14:27:34 UTC
The fix is not in rhvm-4.4.4.1-0.1.el8ev.noarch, therefor moving back to MODIFIED until we get a build with the fix.

Comment 4 Casper (RHV QE bot) 2020-11-26 22:31:30 UTC
This bug has low overall severity and passed an automated regression suite, and is not going to be further verified by QE. If you believe special care is required, feel free to re-open to ON_QA status.

Comment 5 Michael Burman 2020-11-29 09:49:46 UTC
This should be properly tested by QE.

Comment 6 Guy 2020-11-30 07:49:11 UTC
Verified in version 4.4.4.2-0.1.el8ev.noarch

Comment 7 Sandro Bonazzola 2020-12-21 12:35:50 UTC
This bugzilla is included in oVirt 4.4.4 release, published on December 21st 2020.

Since the problem described in this bug report should be resolved in oVirt 4.4.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.