Bug 1885998 - LabPlot broken dependency on cantor due to soname bump
Summary: LabPlot broken dependency on cantor due to soname bump
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: LabPlot
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Christian Dersch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-10-07 12:29 UTC by Christian Dersch
Modified: 2020-10-08 21:29 UTC (History)
6 users (show)

Fixed In Version: LabPlot-2.7.0-5.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-08 21:23:09 UTC
Type: Bug


Attachments (Terms of Use)
Anaconda package log showing failure of Astronomy Spin compose (3.91 KB, text/plain)
2020-10-07 12:33 UTC, Christian Dersch
no flags Details

Description Christian Dersch 2020-10-07 12:29:00 UTC
Description of problem: LabPlot broken dependency on cantor due to soname bump


Version-Release number of selected component (if applicable): LabPlot-2.7.0-2.fc33


How reproducible: always

Steps to Reproduce:
1. dnf install LabPlot

Actual results:
10:56:02,791 WRN packaging: 
 Problem: conflicting requests
  - nothing provides libcantorlibs.so.24()(64bit) needed by LabPlot-2.7.0-2.fc33.x86_64


Expected results: LabPlot installs fine


Additional info: Blocks Astronomy Spin, therefore I'll propose it for F33 final freeze exception

Comment 1 Christian Dersch 2020-10-07 12:33:27 UTC
Created attachment 1719734 [details]
Anaconda package log showing failure of Astronomy Spin compose

Comment 2 Fedora Blocker Bugs Application 2020-10-07 12:43:22 UTC
Proposed as a Freeze Exception for 33-final by Fedora user lupinix using the blocker tracking app because:

 Two days ago an update of cantor reached stable. As this update contains a soname-bump, LabPlot is broken. LabPlot is part of the Astronomy Spin, its build fails for that reason. So we need a freeze exception here to ensure a proper Astronomy Spin compose for F33 release.

Comment 3 Fedora Update System 2020-10-07 12:52:31 UTC
FEDORA-2020-7cfc885657 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7cfc885657

Comment 4 Fedora Update System 2020-10-07 14:30:47 UTC
FEDORA-2020-7cfc885657 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7cfc885657`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7cfc885657

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-10-07 21:58:59 UTC
FEDORA-2020-959409255c has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-959409255c

Comment 6 Mohan Boddu 2020-10-07 21:59:36 UTC
Cantor is updated again with another soname bump, so, I rebuilt LabPlot again and submitted the updated.

Comment 7 Mohan Boddu 2020-10-07 22:05:33 UTC
Okay, I am confused, Labplot-2.7.0-5 was built today without a release bump?

I built LabPlot-2.7.0-6 looking at the changelog and thought it was not built for the cantorlibs soname bump.

Comment 8 Christian Dersch 2020-10-08 08:12:13 UTC
It was built with a release bump from -2 to -5, I checked the changelog and recognized a rebuilt for cantor as its last change, so I merged master into f33 to have them in sync. The F33 update is built against newest cantor-20.08.1-1.fc33 which is fine and goes to stable now. In Rawhide the rebuilt was done weeks ago. cantor 20.08.0 was the breaking package. The bump has just reached F33 tow days ago as 20.08.0 never reached F33, but 20.08.1 did so with https://bodhi.fedoraproject.org/updates/FEDORA-2020-1542afede2

So I think I fixed everything yesterday.

Comment 9 Christian Dersch 2020-10-08 12:14:18 UTC
So for the freeze exception: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7cfc885657 is ready for stable and should do it…

Comment 10 Christian Dersch 2020-10-08 12:33:52 UTC
@Mohan Boddu: Btw, please get in contact with the package maintainer before starting to fix things! I filed the bug (assigned to myself) and submitted the required update correctly. Then you pushed another update… Now on https://qa.fedoraproject.org/blockerbugs/milestone/33/final/buglist we have "pending testing" instead of the correct "pending stable" state thanks to the unnecessary second update.

Comment 11 Adam Williamson 2020-10-08 18:18:16 UTC
+4 on the ticket, marking as accepted FE.

Comment 12 Fedora Update System 2020-10-08 21:23:09 UTC
FEDORA-2020-7cfc885657 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Mohan Boddu 2020-10-08 21:29:13 UTC
@Christian Dersch: I should have checked the koji builds before making the assumption based on the changelog, sorry about that.


Note You need to log in before you can comment on or make changes to this bug.