Bug 1886 - rc.sysinit and sound modules
Summary: rc.sysinit and sound modules
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-30 15:51 UTC by rebel
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-30 16:17:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rebel 1999-03-30 15:51:37 UTC
Sound modules are inserted with no (autoclean) set when in
the rc.sysinit is called "modprobe sound". I think it is not
neccessary to do this.
[The rhsound package can use /dev/sndstat to decide if the
sound is present or not.]

Comment 1 Bill Nottingham 1999-03-30 16:17:59 UTC
It's on purpose to load modules without autoclean
set. Because the DMA in ISA sound cards requires buffers
located below the 16MB mark, unloading and loading the
sound modules a lot can cause them not to work because
they can't allocate the DMA buffers.

(Also, since /dev/sndstat isn't 'functional' until the drivers
are loaded, it can't be used to determine the presence of
sound.)


Note You need to log in before you can comment on or make changes to this bug.