Bug 188624 - raise_on_click: When selecting documents in OOo with the Window menu, selection not raised.
raise_on_click: When selecting documents in OOo with the Window menu, selecti...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 16:10 EDT by Aric
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 22:55:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aric 2006-04-11 16:10:49 EDT
Description of problem:

When raise_on_click is turned off and focus_mode is "sloppy", the selection of
windows in OOo with the Window menu does not work.  When you select a window
with this method, the other window receives the focus, but it is not raised to
the top.  I don't use other applications that allow you to select the document
in a window menu, so I'm not sure if other applications suffer the same problem.

Version-Release number of selected component (if applicable):

2.14.0-1

How reproducible:

100%

Steps to Reproduce:
1. Run gconf-editor, select apps->metacity->general.
2. Click raise_on_click to turn it off.
3. Select System->Preferences->Windows, check "Select windows when mouse moves
over them."
4. Run openoffice.org.  Open two (or more) documents in OOo.
5. Use the Window menu to select various open documents.  The selected documents
are not raised to the top.
6. Uncheck "Select windows when the mouse moves over them"  OR select
raise_on_click, and it works as expected.
  
Actual results:

Focus goes to a window below the top window, but that window is not raised.

Expected results:

Since we're not clicking on a window here, turning off raise_on_click should not
affect the behavior.  Nor should the focus_mode affect the behavior.  The window
that is selected in the menu should be raised to the top regardless.  I suppose
it's possible this is an OOo bug, rather than a metacity bug.  It works as
expected with xfwm4, though.


Additional info:
Comment 1 Søren Sandmann Pedersen 2006-09-07 22:55:54 EDT
This works correctly for me in rawhide.  In any case, this needs to be filed
upstream if it still exists in the latest version.

Note You need to log in before you can comment on or make changes to this bug.