Bug 1886295 - glibc: ldconfig debuginfo file conflict between i686 and x86_64
Summary: glibc: ldconfig debuginfo file conflict between i686 and x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Arjun Shankar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1893694 (view as bug list)
Depends On:
Blocks: 1915330
TreeView+ depends on / blocked
 
Reported: 2020-10-08 06:38 UTC by Ivan Molodetskikh
Modified: 2021-05-25 13:29 UTC (History)
16 users (show)

Fixed In Version: glibc-2.33.9000-6.fc35 glibc-2.33-11.fc34 glibc-2.32-6.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-25 13:29:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Ivan Molodetskikh 2020-10-08 06:38:48 UTC
Description of problem:
Error: Transaction test error:
  file /usr/lib/debug/sbin/ldconfig.debug conflicts between attempted installs of glibc-debuginfo-2.32-1.fc33.x86_64 and glibc-debuginfo-2.32-1.fc33.i686
  file /usr/lib/debug/usr/bin/makedb.debug conflicts between attempted installs of glibc-debuginfo-2.32-1.fc33.x86_64 and glibc-debuginfo-2.32-1.fc33.i686
  file /usr/lib/debug/usr/libexec/glibc-benchtests/bench-acos.debug conflicts between attempted installs of glibc-debuginfo-2.32-1.fc33.x86_64 and glibc-debuginfo-2.32-1.fc33.i686
  file /usr/lib/debug/usr/libexec/glibc-benchtests/bench-acosh.debug conflicts between attempted installs of glibc-debuginfo-2.32-1.fc33.x86_64 and glibc-debuginfo-2.32-1.fc33.i686
and so on and so forth.

Version-Release number of selected component (if applicable):
glibc-debuginfo-2.32-1

How reproducible:
Always

Steps to Reproduce:
1. sudo dnf debuginfo-install glibc

Comment 1 Florian Weimer 2020-10-08 07:25:59 UTC
ldconfig.debug etc. need to be in glibc-debuginfo-common. It was this way many, many years ago.

In Fedora 32 and earlier, DNF/RPM do not complain about this, which is why it went unnoticed.

Comment 2 Florian Weimer 2020-10-13 13:14:53 UTC
I'm going to attempt a fix.

Comment 3 Ivan Molodetskikh 2020-11-01 05:13:14 UTC
Any updates? I happened to need i686 glibc debuginfo and looks like this is still an issue, so I had to remove the x86_64 debuginfo.

Comment 4 Florian Weimer 2020-11-02 11:41:45 UTC
*** Bug 1893694 has been marked as a duplicate of this bug. ***

Comment 5 Jean-François Fortin Tam 2020-12-20 15:13:51 UTC
Same here, on systems where glibc is installed both in 64-bit and 32-bit versions, if I try to dnf debuginfo-install glibc it tries to install it for both architectures and I get a bunch of conflicting files, including pretty much the whole /usr/lib/debug/usr/libexec/glibc-benchtests/ folder, plus the files mentioned above, plus /usr/lib/debug/usr/sbin/iconvconfig.debug

(Unfortunately my systems end up still having some 32-bit packages installed, including glibc, because an infamous 32-bit PDF reader application is the only way to deal with the government's XFA forms.)

Comment 7 Ben Cotton 2021-02-09 15:20:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 8 David M. Lloyd 2021-04-27 17:20:47 UTC
I encountered this problem on 33, so it's not just rawhide that is impacted.

Comment 10 Fedora Update System 2021-05-20 14:01:42 UTC
FEDORA-2021-2ba993d6c5 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-2ba993d6c5

Comment 11 Fedora Update System 2021-05-21 03:56:14 UTC
FEDORA-2021-2ba993d6c5 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-2ba993d6c5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-2ba993d6c5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-05-22 01:07:57 UTC
FEDORA-2021-2ba993d6c5 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Arjun Shankar 2021-05-25 13:05:39 UTC
Fixed in Fedora 33 in version glibc-2.32-6.fc33.


Note You need to log in before you can comment on or make changes to this bug.