Bug 188635 - tcpwrapped sendmail does not accept hosts.deny entries
tcpwrapped sendmail does not accept hosts.deny entries
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcp_wrappers (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 18:44 EDT by Roman Rozinov
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-10 09:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rozinov 2006-04-11 18:44:05 EDT
Description of problem:
sendmail-8.13.1-2 appears to be compiled with libwrap.so.0 due to the command
ldd /usr/sbin/sendmail.
However, after specifying ALL: ALL in hosts.deny, i am able to connect to
sendmail's port 25

Version-Release number of selected component (if applicable):
sendmail-8.13.1-2

How reproducible:


Steps to Reproduce:
1. specify ALL: ALL in hosts.deny
2. restart sendmail service
3. connect from another machine to port 25

  
Actual results:
connects every time

Expected results:
connection should be refused

Additional info:
Comment 1 Tomas Janousek 2007-01-18 10:24:48 EST
sendmail rejects the mail after issuing the MAIL command, there is no need to
reject the whole connection. And it's not a tcp_wrappers bug neither.
Comment 3 Tomas Janousek 2007-04-06 08:42:00 EDT
Can you confirm that it's ok so that I can close the report?
Comment 4 Tomas Janousek 2007-05-10 09:19:25 EDT
No reply for more than a month, closing. Feel free to reopen if you still
believe this is a bug.

Note You need to log in before you can comment on or make changes to this bug.