Bug 188637 - Loading certain web sites in Firefox or Mozilla locks up the system
Loading certain web sites in Firefox or Mozilla locks up the system
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 19:12 EDT by Mark Nagy
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 05:33:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bzipped output from a session of "strace mozilla", which ended in a crash as described for this bug (71.25 KB, application/x-bzip)
2006-04-11 19:15 EDT, Mark Nagy
no flags Details

  None (edit)
Description Mark Nagy 2006-04-11 19:12:08 EDT
Description of problem:

After I attempt to load one of certain web sites using Mozilla or Firefox with
FC5, the system becomes completely unresponsive; no key combinations or mouse
actions appear to have eny effect, nor anything short of reset or a power cycle.
 Even ssh sessions from remote machine, if any, become unresponsive.  This does
not happen with either Mozilla or Firefox under CentOS 4.3, or Konqueror under
FC5, using the same hardware.

Version-Release number of selected component (if applicable):

mozilla-1.7.12-5
firefox 1.5.0.1-9
(as I type this, these appear to be the latest available, since I just ran a yum
update on the machine in question)

How reproducible:

Completely, so far as I can tell.  I have tried loading the page listed below
under "steps to reproduce" several times over about a week, the last one right
before typing this, and it has happened every time.  I do not know whether it
happens with other hardware using FC5, but since switching browsers under FC5 or
switching Linux versions, as mentioned in the problem description, allows the
page to load without incident, it does not seem to be merely a hardware problem.  

Steps to Reproduce:
1.  Start Mozilla or Firefox under FC5
2.  Make sure nothing is going on that you would really hate the system to crash
in the middle of
3.  Navigate to
http://www.prisonplanet.com/articles/march2006/230306googlecensoring.htm
  
Actual results:

System becomse completely unresponsive, and all evidence of processes continuing
to run ceases, until a reset or power cycle.

Expected results:

The page should load without difficulty, as it does both in CentOS 4.3's Mozilla
and Firefox and FC5's Konqueror

Additional info:

I will attach strace output from one of the crashes, FWIW, and will supply other
hardware or software configuration details if requested.  I do not know whether
the problem has any hardware-specific aspects, but I do know that switching
either browsers or Linux releases on the same hardware, as described above,
allows the page to load without incident, so I can at least say it isn't
strictly a hardware problem.
Comment 1 Mark Nagy 2006-04-11 19:15:38 EDT
Created attachment 127637 [details]
Bzipped output from a session of "strace mozilla", which ended in a crash as described for this bug
Comment 2 Alex Kloss 2006-05-02 18:33:42 EDT
After testing this on a fully patched version of Fedora Core 5, I was unable to 
reproduce this bug. It appears that the latest version (1.5.0.2-1) has patched 
this bug.
Comment 3 Mark Nagy 2006-05-02 21:18:37 EDT
I just reproduced the problem on the machine where I had verified it right
before filing the bug report; then I turned off ACPI in the BIOS and was able to
load the page without any trouble.  As I mentioned, loading the page on CentOS 4
does not cause a lockup - even with the ACPI on, as it was until now.  More
recently I have tried the same thing with Fedora Core 4, and that doesn't lock
up the system when the ACPI is on either.  The system that locks up has a
Biostar M7NCD Pro motherboard (i.e., it is NForce2-based) and does not appear to
be unstable in general.  So it doesn't seem to be a matter of bad hardware, but
it seems to have something to with the way ACPI is handled on at least some
hardware by FC5.
Comment 4 Mark Nagy 2006-05-10 06:47:51 EDT
Several recent updates still do not seem to have fixed this bug, but adding
"acpi=off" to the "kernel" line in grub.conf seems to be an effective workaround.
Comment 5 Todd Fredrich 2006-05-17 10:57:37 EDT
Just FYI, I am experiencing this same issue with FC5 (with all the latest
updates) on a Dell Dimension 9150 (Pentium D).  The above mentioned "acpi=off"
work-around had no affect.  This bug renders FC5 useless to me at the present
time--as I utilize Mozilla/Firefox in my software development cycle.
Comment 6 Mark Nagy 2006-06-21 05:35:25 EDT
With the latest updates I can now load the web page I was using to test this
without having to use acpi=off to prevent a crash.  However, in light of the
previous comment, and the fact that the web page might have changed since over a
month ago when I last checked, I don't know whether this means the bug has been
fixed or not.
Comment 7 Matěj Cepl 2007-07-18 13:31:21 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 8 Mark Nagy 2007-07-19 23:40:10 EDT
As I said, I wasn't seeing the problem anymore by 2006-06-21, and I don't see
any comments after that indicating that anyone else was either, nor do I recall
seeing any system lockups that seemed related to Firefox on Fedora since then. 
The last time I mentioned the subject, over a year ago, FC5 was still supported,
whereas now it has been quite a while since I used either it or the hardware
configuration where I first saw the bug (and the bug did appear to show up only
with certain hardware configurations).  I don't have a system physically set up
that way anymore, or anything else (like a Dell Dimension 9150) where I would
have known to expect the problem even way back when it first appeared.  So my
guess would be that the bug was fixed, but I don't think I am in any better
position to verify that now than anybody else.
Comment 9 Matěj Cepl 2007-07-20 05:33:42 EDT
Closing per reporter's comment.

Note You need to log in before you can comment on or make changes to this bug.