Bug 1886401 - Regression - infra and audit index pattern are not created automatically in Kibana contrary to previous versions
Summary: Regression - infra and audit index pattern are not created automatically in K...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.7.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-08 11:50 UTC by Ilan Green
Modified: 2020-11-27 13:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-11 00:50:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ilan Green 2020-10-08 11:50:32 UTC
Description of problem:
With the new EFK stack for OCP 4.5 the indices are not created as was the case with previous versions of OCP prior to 4.5

Version-Release number of selected component (if applicable):
Default efk stack for ocp 4.5 and higher

How reproducible:
New install of OCP 4.5 cluster logging
Upgrade to OCP 4.5 cluster logging

Steps to Reproduce:
1.
2.
3.

Actual results:
No indices available

Expected results:
Having Indices created as was the case with prior versions

Additional info:
This is, rightly, perceived as a huge hassle to the customer.
Having over 50 clusters with hundreds of users
Creating new development and testing clusters - it becomes a real hog
Having each developer spend time doing it let alone the cost of educating the users
Overall lots of hassle and noise

Comment 1 Stephen Cuppett 2020-10-08 13:24:36 UTC
Setting target release to the active development branch (4.7.0) for consideration/evaluation/triage. Where requested, appropriate and fixes available, clones will be created for prior releases once a resolution is determined.

Comment 3 Jeff Cantrill 2020-10-11 00:50:36 UTC
(In reply to Ilan Green from comment #0)

> Additional info:
> This is, rightly, perceived as a huge hassle to the customer.
> Having over 50 clusters with hundreds of users
> Creating new development and testing clusters - it becomes a real hog
> Having each developer spend time doing it let alone the cost of educating
> the users

Regular user's will need to create one index-pattern the first time they log into Kibana.  Admin user's will need to create three.  The steps are well documented in the logging section of the OpenShift documentation and literally amounts to a sum total of three steps.

Please work with PM to open an RFE if you feel this requires further attention as the functionality is as intended per discussions during release planning.  Closing NOTABUG

[1] https://docs.openshift.com/container-platform/4.5/logging/viewing/cluster-logging-visualizer.html#cluster-logging-visualizer-indices_cluster-logging-visualizer

Comment 4 Ilan Green 2020-10-11 14:21:26 UTC
(In reply to Jeff Cantrill from comment #3)
> (In reply to Ilan Green from comment #0)
> 
> > Additional info:
> > This is, rightly, perceived as a huge hassle to the customer.
> > Having over 50 clusters with hundreds of users
> > Creating new development and testing clusters - it becomes a real hog
> > Having each developer spend time doing it let alone the cost of educating
> > the users
> 
> Regular user's will need to create one index-pattern the first time they log
> into Kibana.  Admin user's will need to create three.  The steps are well
> documented in the logging section of the OpenShift documentation and
> literally amounts to a sum total of three steps.
> 
> Please work with PM to open an RFE if you feel this requires further
> attention as the functionality is as intended per discussions during release
> planning.  Closing NOTABUG
> 
> [1]
> https://docs.openshift.com/container-platform/4.5/logging/viewing/cluster-
> logging-visualizer.html#cluster-logging-visualizer-indices_cluster-logging-
> visualizer

Would it be possible please to share the rationale for this change compared with previous versions (i.e. the "discussions during release planning")?
As noted in the description this will soon become a real hassle for large customers with large development environments where cluster creation is frequent

Thanks


Note You need to log in before you can comment on or make changes to this bug.