Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1886550 - [RFE] Satellite should alarm certificate (puppet) expiry for content hosts
Summary: [RFE] Satellite should alarm certificate (puppet) expiry for content hosts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Certificates
Version: 6.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Omkar Khatavkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-08 18:12 UTC by Dhananjay Pramod Mule
Modified: 2020-10-14 13:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-14 13:40:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dhananjay Pramod Mule 2020-10-08 18:12:25 UTC
Description of problem:
Satellite server shows the expiry dates of puppet client certificate with puppet API https://capsule.example.com:9090/puppet/ca 

But it would be helpful to receive alter on the Red Hat Satellite dashboard, probably 4-5 days before the client certificate expires.

Version-Release number of selected component (if applicable):
satellite-6.7.3 (applicable to other version as well)

How reproducible:NA


Steps to Reproduce:NA
1.
2.
3.

Actual results:
The data is visible on https://capsule.example.com:9090/puppet/ca but it is not present consolidated form.

Expected results:
Satellite should display the puppet client certificate expiry on dashboard 4-5 days before the client certificate expires. To prevent the  


Additional info:

Comment 1 Sean O'Keeffe 2020-10-14 13:40:23 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support.
Thank you


Note You need to log in before you can comment on or make changes to this bug.