Bug 1886561 - RPM spec file syntax highlighting is not working
Summary: RPM spec file syntax highlighting is not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nano
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-10-08 18:39 UTC by Neal Gompa
Modified: 2020-10-12 21:57 UTC (History)
7 users (show)

Fixed In Version: nano-5.3-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-12 21:57:09 UTC
Type: Bug
kdudka: needinfo-


Attachments (Terms of Use)

Description Neal Gompa 2020-10-08 18:39:38 UTC
Description of problem:
I upgraded from Fedora 32 to Fedora 33, and now RPM spec syntax highlighting isn't working.

Version-Release number of selected component (if applicable):
5.2-1.fc33

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 33
2. Download https://src.fedoraproject.org/rpms/nano/raw/master/f/nano.spec
3. Open nano.spec with nano

Actual results:
nano.spec only has shell comments and email addresses highlighted (basic text file highlighting).

Expected results:
nano.spec has full syntax highlighting just like in nano on Fedora 32.

Comment 1 Neal Gompa 2020-10-08 18:52:24 UTC
I have made a PR that attempts to fix this: https://src.fedoraproject.org/rpms/nano/pull-request/3

Comment 2 Fedora Blocker Bugs Application 2020-10-08 19:13:33 UTC
Proposed as a Freeze Exception for 33-final by Fedora user chrismurphy using the blocker tracking app because:

 Lack of syntax highlighting can be slightly aggravating, and nano is now the default editor. While it can be fixed with an update, it's preferred that the problem isn't happening on all our media.

Comment 3 Fedora Update System 2020-10-08 19:38:15 UTC
FEDORA-2020-49d1a285d5 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-49d1a285d5

Comment 4 Fedora Update System 2020-10-08 22:20:31 UTC
FEDORA-2020-49d1a285d5 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-49d1a285d5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-49d1a285d5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Kamil Dudka 2020-10-09 09:21:29 UTC
Neal Gompa, I find it inappropriate that you directly pushed your changes immediately after opening the pull request, without giving anybody chance to comment on this.  You are not listed as member at https://src.fedoraproject.org/rpms/nano/ so you should discuss non-trivial changes with maintainers before pushing them directly.

Comment 6 Neal Gompa 2020-10-09 16:28:54 UTC
(In reply to Kamil Dudka from comment #5)
> Neal Gompa, I find it inappropriate that you directly pushed your changes
> immediately after opening the pull request, without giving anybody chance to
> comment on this.  You are not listed as member at
> https://src.fedoraproject.org/rpms/nano/ so you should discuss non-trivial
> changes with maintainers before pushing them directly.

I moved it and decided to merge it because it retains continuity of syntax highlight support from the previous versions shipped in Fedora 33 and older Fedora releases.

When the grammars were moved out to the `extra` directory in the 5.0 release, the notes[1] said the following:

> Distro-specific syntaxes, and syntaxes of less common languages,
> have been moved down to subdirectory syntax/extra/. The affected
> distros and others may wish to move wanted syntaxes one level up.

To me, that says that we _should_ just move it back up.

[1]: https://www.nano-editor.org/news.php

Comment 7 Kamil Dudka 2020-10-10 07:10:21 UTC
This is not an excuse.  To me, this looks like misuse of your provenpackager privileges.  See the Policy for provenpackagers:

    "They should be careful not to change other people’s packages needlessly and try to do the minimal changes required to fix problems, ..."

I do not think this was so urgent that the changes could not be reviewed before pushing them.

Comment 8 Neal Gompa 2020-10-10 11:17:30 UTC
(In reply to Kamil Dudka from comment #7)
> This is not an excuse.  To me, this looks like misuse of your provenpackager
> privileges.  See the Policy for provenpackagers:
> 
>     "They should be careful not to change other people’s packages needlessly
> and try to do the minimal changes required to fix problems, ..."
> 
> I do not think this was so urgent that the changes could not be reviewed
> before pushing them.

Perhaps you're right. I made a judgement call based on trying to ensure that this would be on the media and in the live environments. It probably could have waited a couple of days.

Comment 9 sumantro 2020-10-11 05:10:53 UTC
This is fixed by update

Comment 10 Geoffrey Marr 2020-10-12 19:34:27 UTC
Discussed during the 2020-10-12 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException (Final)" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-10-12/f33-blocker-review.2020-10-12-16.00.txt

Comment 11 Adam Williamson 2020-10-12 20:38:49 UTC
Kamil: before we push this update, can we ask you to say whether you agree or disagree with the change, disregarding provenpackager process issues? Thanks!

FWIW, I think the change makes sense, I've read the upstream commit messages and thread and don't really buy the rationale for moving these syntaxes at all. The only justification upstream seemed to provide is that they somehow "burden" nano, but I don't see how at all. If you don't edit files of the relevant type they don't bother you, and if you do, highlighting is good.

Comment 12 Kamil Dudka 2020-10-12 21:22:41 UTC
Adam, please feel free to push the update.  The problem I pointed out can be fixed by a subsequent update if needed.

Comment 13 Fedora Update System 2020-10-12 21:57:09 UTC
FEDORA-2020-49d1a285d5 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.