Bug 1886774 - Blue area appears when resize a spice RHEL8 vm window by mouse via virt-viewer
Summary: Blue area appears when resize a spice RHEL8 vm window by mouse via virt-viewer
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virt-viewer
Version: 8.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Default Assignee for SPICE Bugs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-09 11:39 UTC by zhoujunqin
Modified: 2020-11-23 07:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-23 07:46:56 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Screenshot when resizing the vm's window (278.30 KB, image/png)
2020-10-09 11:50 UTC, zhoujunqin
no flags Details
Debug log for the virt-viewer (190.39 KB, text/plain)
2020-10-09 11:52 UTC, zhoujunqin
no flags Details

Description zhoujunqin 2020-10-09 11:39:54 UTC
Description of problem:
Blue area appears when resize a spice vm window by mouse via virt-viewer 

Version-Release number of selected component (if applicable):
libvirt-6.0.0-28.module+el8.3.0+7827+5e65edd7.x86_64
virt-viewer-9.0-4.el8.x86_64
spice-gtk3-0.38-3.el8.x86_64
qemu-kvm-5.1.0-9.module+el8.3.0+8182+ac9ced32.x86_64
kernel-4.18.0-240.el8.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Prepare a spice RHEL8 vm:  
Display: spice + Video: qxl + spice-vdagentd.service is running)
spice-vdagent-0.20.0-1.el8.x86_64
kernel-4.18.0-240.el8.x86_64

2. Run virt-viewer to connect to the guest.
$ virt-viwer -c qemu:///system xxx

3. Resize the vm's window(dragging the virt-viewer window by mouse).

4. Check the vm's resolution.

Actual results:
The vm's resolution changes as expect, but there are blue areas appears when resizing the window.
Then change to 'Fullscreen' mode, the blue areas disappears, but the blue areas appears when changing back to window mode.

Please see attachments for details, thanks.

Expected results:
Fix it.

Additional info:
Can't reproduce this issue with RHEL7 vm.

Comment 1 zhoujunqin 2020-10-09 11:50:20 UTC
Created attachment 1720219 [details]
Screenshot when resizing the vm's window

Comment 2 zhoujunqin 2020-10-09 11:52:21 UTC
Created attachment 1720220 [details]
Debug log for the virt-viewer

Comment 3 Julien Ropé 2020-11-23 07:46:56 UTC
If I understand your description, and looking at your screenshot, it is just the desktop image not filling the new desktop size.

I have tried and reproduced this behaviour. As you mention, the screen resolution is properly updated, so SPICE is working as expected.
Now in the guest, the background image is set to "scale", which means the image resizes only to the limits of its ratio. If you pick a resolution that is not standard, the scaling cannot fill the screen, and the parts of the background that is not filled with the image is showing the default background color (blue).
When you set the window to fullscreen, it gets a standard resolution (the one from your monitor), and the problem disapears.

This can be verified by issuing the following command:

$ dconf write /org/gnome/desktop/background/picture-options "'zoom'"

This will set the desktop image to "zoom" rather than "scale", and make it fill the desktop whatever its size.

I guess the default has changed since RHEL7, which is why it didn't happen before?


Note You need to log in before you can comment on or make changes to this bug.