Bug 1886855 - ovn-cert is mandatory in both master and node daemonsets
Summary: ovn-cert is mandatory in both master and node daemonsets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Juan Luis de Sousa-Valadas
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On: 1886834
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-09 14:23 UTC by Juan Luis de Sousa-Valadas
Modified: 2020-10-27 16:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 835 0 None closed Bug 1886855: Make ovn-cert secret mandatory for both master and node 2020-12-21 09:14:16 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:48:11 UTC

Description Juan Luis de Sousa-Valadas 2020-10-09 14:23:16 UTC
This bug was initially created as a copy of Bug #1886834

I am copying this bug because: 



Description of problem:
ovn-kubernetes requires ovn-cert, this was accidentally set to optional.

Version-Release number of selected component (if applicable):
4.6 CI and master

How reproducible:
always

Steps to Reproduce:
N/A

Actual results:
secret mount is optional

Expected results:

secret mount is mandatory

Additional info:

Comment 1 Dan Williams 2020-10-12 20:16:52 UTC
PUlling back to 4.6 since this appears to be an install test blocker.

Comment 4 zhaozhanqi 2020-10-15 08:56:15 UTC
Verified this bug on 4.6 rc.4.

Comment 7 errata-xmlrpc 2020-10-27 16:47:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.