Bug 1886910 - 4.6 RHCOS osImage is not following openshift/kubernetes
Summary: 4.6 RHCOS osImage is not following openshift/kubernetes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Micah Abbott
QA Contact: Steve Milner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-09 17:55 UTC by Seth Jennings
Modified: 2020-10-27 16:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:48:11 UTC

Description Seth Jennings 2020-10-09 17:55:37 UTC
Description of problem:
The RHCOS image and osImages for 4.6 rc's have a week old version of hyperkube in them

Version-Release number of selected component (if applicable):
4.6.0-rc1

How reproducible:
Always

Steps to Reproduce:
1. Install cluster and get kubelet version as v1.19.0+db1fc96 which is from 1w ago https://github.com/openshift/kubernetes/commit/db1fc96

Actual results:
Old hyperkube

Expected results:
hyperkube built from latest o/k release-4.6

Additional info:

Comment 1 Seth Jennings 2020-10-09 17:56:29 UTC
Bug requested by Eric for tracking release blocking situation

Comment 2 Steve Milner 2020-10-09 18:08:37 UTC
Builds are in process by ART as of around 50 minutes ago.

Comment 4 Seth Jennings 2020-10-09 19:04:07 UTC
Fortunately, David made the only PR that is missing

$ git log --oneline --no-merges db1fc96..openshift/release-4.6
d339db6dbb3 UPSTREAM: 95364: set lastterminationstate for container status even when CRI fails to return termination (or any) data

Comment 7 Steve Milner 2020-10-12 13:50:16 UTC
Updated package is available in 4.6.0-0.nightly-2020-10-09-153352 (46.82.202010081751-0) roughly as of Friday late afternoon. The same for CI builds.

There were two package updates on Friday:

- 4.6.0-202010081244.p0.git.94033.c107fa2.el8
- 4.6.0-202010081843.p0.git.94035.af27205.el8

Marking verified.

Comment 10 errata-xmlrpc 2020-10-27 16:47:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.