Bug 1886947 - Cluster-version operator fills logs with "Manifest: ..." spew
Summary: Cluster-version operator fills logs with "Manifest: ..." spew
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: W. Trevor King
QA Contact: liujia
URL:
Whiteboard:
Depends On: 1886900
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-09 19:14 UTC by OpenShift BugZilla Robot
Modified: 2020-10-27 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-version-operator pull 471 0 None closed [release-4.6] Bug 1886947: pkg/cvo/sync_worker: Drop "Manifest: ..." logging 2021-01-19 10:56:43 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:48:11 UTC

Description OpenShift BugZilla Robot 2020-10-09 19:14:44 UTC
+++ This bug was initially created as a clone of Bug #1886900 +++

Since bug 1873900's [1], we've had lots of log noise like:

  I1009 15:40:43.074056       1 sync_worker.go:702] Manifest: {"apiVersion...

This line is descended from logging we grew way back in [2].  But we triggered it recently with the bump to v5 in [1].  We should drop the line, because it's noisy spew in the log files, and we can get the manifest content via:

  $ oc adm release extract --to=manifests $PULLSPEC

[1]: https://github.com/openshift/cluster-version-operator/pull/448
[2]: https://github.com/openshift/cluster-version-operator/pull/14

Comment 1 Scott Dodson 2020-10-09 19:45:03 UTC
Trevor tells me this is a regression in 4.6 and it yields a nearly 8x increase in log rate so moving back to 4.6.0.

Comment 3 liujia 2020-10-10 07:30:12 UTC
Reproduced on 4.6.0-rc.1

# ./oc logs cluster-version-operator-79d45f4784-wsvlm > rc1-cvo.log
# cat rc1-cvo.log |grep "sync_worker.go:702"|wc -l
3189
# cat rc1-cvo.log |grep "sync_worker.go:702"|tail -n2
I1010 06:53:18.130079       1 sync_worker.go:702] Manifest: {"apiVersion":"apps/v1","kind":"Deployment","metadata":{"annotations":{"exclude.release.openshift.io/internal-openshift-hosted":"true","include.release.openshift.io/self-managed-high-availability":"true"},"labels":{"app":"openshift-config-operator"},"name":"openshift-config-operator","namespace":"openshift-config-operator"},"spec":{"replicas":1,"selector":{"matchLabels":{"app":"openshift-config-operator"}},"strategy":{"type":"Recreate"},"template":{"metadata":{"labels":{"app":"openshift-config-operator"},"name":"openshift-config-operator"},"spec":{"containers":[{"command":["cluster-config-operator","operator"],"env":[{"name":"IMAGE","value":"quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:25197b2709c0691c28424c9b07e505a71d13bf481e18bc42636cc84ee8fef033"},{"name":"OPERATOR_IMAGE_VERSION","value":"4.6.0-rc.1"},{"name":"OPERAND_IMAGE_VERSION","value":"4.6.0-rc.1"}],"image":"quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:25197b2709c0691c28424c9b07e505a71d13bf481e18bc42636cc84ee8fef033","imagePullPolicy":"IfNotPresent","livenessProbe":{"httpGet":{"path":"/healthz","port":8443,"scheme":"HTTPS"},"initialDelaySeconds":3,"periodSeconds":3},"name":"openshift-config-operator","ports":[{"containerPort":8443,"name":"metrics","protocol":"TCP"}],"readinessProbe":{"httpGet":{"path":"/healthz","port":8443,"scheme":"HTTPS"},"initialDelaySeconds":3,"periodSeconds":3},"resources":{"requests":{"cpu":"10m","memory":"50Mi"}},"terminationMessagePolicy":"FallbackToLogsOnError","volumeMounts":[{"mountPath":"/var/run/secrets/serving-cert","name":"serving-cert"}]}],"nodeSelector":{"node-role.kubernetes.io/master":""},"serviceAccountName":"openshift-config-operator","tolerations":[{"effect":"NoSchedule","key":"node-role.kubernetes.io/master","operator":"Exists"},{"effect":"NoExecute","key":"node.kubernetes.io/unreachable","operator":"Exists","tolerationSeconds":120},{"effect":"NoExecute","key":"node.kubernetes.io/not-ready","operator":"Exists","tolerationSeconds":120}],"volumes":[{"name":"serving-cert","secret":{"optional":true,"secretName":"config-operator-serving-cert"}}]}}}}
I1010 06:53:18.278386       1 sync_worker.go:702] Manifest: {"apiVersion":"config.openshift.io/v1","kind":"ClusterOperator","metadata":{"annotations":{"exclude.release.openshift.io/internal-openshift-hosted":"true","include.release.openshift.io/self-managed-high-availability":"true"},"name":"config-operator"},"spec":{},"status":{"versions":[{"name":"operator","version":"4.6.0-rc.1"}]}}

Comment 6 liujia 2020-10-12 03:26:23 UTC
Verified on 4.6.0-0.nightly-2020-10-10-041109

# ./oc logs cluster-version-operator-6bc6c897cb-w8xkf > nightly-cvo.log
# cat nightly-cvo.log |grep "sync_worker.go:702"|wc -l
0

Comment 9 errata-xmlrpc 2020-10-27 16:47:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.