Bug 1887012 - F32FailsToInstall: python-httpx
Summary: F32FailsToInstall: python-httpx
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-httpx
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carl George 🤠
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1951824 1951825
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-10 04:15 UTC by Xoloitzcuintle
Modified: 2021-04-29 14:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-29 14:45:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Xoloitzcuintle 2020-10-10 04:15:27 UTC
Package requires python-httpcore and python-rfc3986 newer versions.


python3-httpx-0.16.1-1.fc32.noarch


How reproducible:
Always

Steps to Reproduce:
1. Update the package (In my case, 15.4 (from my Copr) to 0.16.1))

Actual results:

Error: 
 Problem: cannot install the best update candidate for package python3-httpx-0.15.4-1.fc32.noarch
  - nothing provides (python3.8dist(httpcore) >= 0.12 with python3.8dist(httpcore) < 0.13) needed by python3-httpx-0.16.1-1.fc32.noarch
  - nothing provides (python3.8dist(rfc3986) >= 1.3 with python3.8dist(rfc3986) < 2) needed by python3-httpx-0.16.1-1.fc32.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Expected results:
Dependencies resolved.
Nothing to do.
Complete!

Comment 1 Carl George 🤠 2021-04-20 23:03:39 UTC
I've submitted httpcore and rfc3986 updates for f32 to resolve this, please see the dependent bugs for the relevant bodhi update to test and provide karma.

Comment 2 Carl George 🤠 2021-04-29 14:45:16 UTC
I can now install python3-httpx on f32.


Note You need to log in before you can comment on or make changes to this bug.