Bug 188704 - remuxing AAC audio produces broken files
remuxing AAC audio produces broken files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libebml (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 09:18 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-23 05:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2006-04-12 09:18:45 EDT
Description of problem:
There's a bug in libebml-0.7.6 with float variables aliasing which breaks AAC
muxing when compiled with gcc-4.1. It has been fixed in 0.7.7 (I've tested it
myself), so please update and rebuild.

Version-Release number of selected component (if applicable):
libebml-0.7.6-2.fc5

How reproducible:
Always

Steps to Reproduce:
1. Take any mkv/mp4/mov file containing AAC audio
2. Remux it into a new mkv file using mkvmerge/mmg
  
Actual results:
Playing the new file with MPlayer makes libfaad spit a lot of:
FAAD: Failed to decode frame: Maximum number of scalefactor bands exceeded
and audio playback fails.

Expected results:
AAC audio should play without errors.
Comment 1 Dams 2006-04-12 10:30:25 EDT
0.7.7 commited. 
Comment 2 Hans de Goede 2006-07-23 05:09:17 EDT
I'm taking over as maintainer from Anvil, since Anvil has other priorities.
0.7.7-1 has been build and published a long time ago, closing.


Note You need to log in before you can comment on or make changes to this bug.