Bug 1887155 - cluster-node-tuning-operator refers to missing cluster-node-tuned image
Summary: cluster-node-tuning-operator refers to missing cluster-node-tuned image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Jiří Mencák
QA Contact: Simon
URL:
Whiteboard:
: 1887089 (view as bug list)
Depends On: 1887088
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-11 11:30 UTC by OpenShift BugZilla Robot
Modified: 2020-10-27 16:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-node-tuning-operator pull 166 0 None closed [release-4.6] Bug 1887155: image-references: no longer require cluster-node-tuned 2020-11-09 12:29:43 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:48:11 UTC

Description OpenShift BugZilla Robot 2020-10-11 11:30:48 UTC
+++ This bug was initially created as a clone of Bug #1887088 +++

Description of problem:
Per https://issues.redhat.com/browse/ART-2044 the tuned container is obsolete. However it is still referred to in cluster-node-tuning-operator (and thus the CVO) as cluster-node-tuned. This blocks forming a nightly.

Actual results:
https://amd64.ocp.releases.ci.openshift.org/releasestream/4.7.0-0.nightly/release/4.7.0-0.nightly-2020-10-10-172258 shows
> error: unable to create a release: operator "cluster-node-tuning-operator" contained an invalid image-references file: no input image tag named "cluster-node-tuned"

Expected results:
no reference to "cluster-node-tuned" tag

Additional info:
4.6 has a similar reference. It is currently fulfilled by a two-month-old tag. I'll clone this bug for that, but as long as it's not actually in use by anything, it may not require removal from the nightly for GA, although that would be ideal. 

It doesn't look like any manifest has referred to this image since 4.3, so you may want to backport the change through 4.4.

Comment 1 Luke Meyer 2020-10-11 20:49:30 UTC
*** Bug 1887089 has been marked as a duplicate of this bug. ***

Comment 3 Simon 2020-10-13 19:07:04 UTC
Verified for v. 4.6.0-rc.3-x86_64

cluster-node-tuning-operator
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:72323ce541f8a26fbad17ef65ff21b51498863bb851635a0faa8d5b1ac6ce0e4
             io.openshift.build.commit.url=https://github.com/openshift/cluster-node-tuning-operator/commit/e53f74375d6e9a613ba41100d572f80c37698eff
             url=https://access.redhat.com/containers/#/registry.access.redhat.com/openshift/ose-cluster-node-tuning-operator/images/v4.6.0-202010121848.p0


No image for cluster-node-tuned

Comment 6 errata-xmlrpc 2020-10-27 16:47:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.