Bug 1887176 - Ecliple wont start after install.
Summary: Ecliple wont start after install.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 32
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1895529 1925966 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-11 14:48 UTC by pwrzonca
Modified: 2021-04-23 11:26 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-08 15:36:32 UTC
Type: Bug


Attachments (Terms of Use)
logfile (686.60 KB, text/plain)
2020-10-11 14:48 UTC, pwrzonca
no flags Details

Description pwrzonca 2020-10-11 14:48:38 UTC
Created attachment 1720675 [details]
logfile

Description of problem:
Ecliple wont start after install.

Version-Release number of selected component (if applicable):
fedora 32, eclipse 2020-06

How reproducible:


Steps to Reproduce:
1. Install eclipse
2. Try to start it
3.

Actual results:

Error massage that direct me to read log which doesn't say too much for me.

Expected results:


Additional info:

Comment 1 pwrzonca 2020-11-08 20:22:49 UTC
When you install cuda as described in rpmfusion cuda howto AND THEN you install eclipse you broke eclipse for some reason. It can be fixed as I described in https://ask.fedoraproject.org/t/eclipse-failes-to-start-fresh-install/10198/12

Comment 2 Fedora Admin user for bugzilla script actions 2021-03-24 00:21:03 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 3 Vladimir Florinski 2021-04-07 17:40:55 UTC
I don't think cuda is to blame. The errors you see are all caused by the missing sac. Just install sac with dnf and eclipse should start.

Comment 4 Alexander Kurtakov 2021-04-08 09:07:48 UTC
Eclipse has dependency on sac already I don't see how can one install it without sac. Is the issue reproducible on F33 or F34 beta?

Comment 5 Vladimir Florinski 2021-04-08 15:19:52 UTC
It turns out that cuda-nvvp (Visual Profiler) also provides "osgi(org.w3c.css.sac)", but it is installed in a non-standard place. The same is true for sat4j, and both RPMs must be installed to make eclipse functional if it is installed after CUDA. So it looks like a CUDA issue indeed and not a Fedora bug.

Comment 6 Mat Booth 2021-04-08 15:36:32 UTC
There's nothing we can do here to fix rpmfusion packages :-(

Please file a bug with the cuda package and get them to fix their dependencies (they should BR/R sac and sat4j from main Fedora repos instead of providing their own copy.)

Comment 7 Alexander Kurtakov 2021-04-23 11:23:54 UTC
*** Bug 1895529 has been marked as a duplicate of this bug. ***

Comment 8 Alexander Kurtakov 2021-04-23 11:26:28 UTC
*** Bug 1925966 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.