Bug 1887353 - Review Request: rust-owned_ttf_parser - Support for owned data on top of ttf-parser
Summary: Review Request: rust-owned_ttf_parser - Support for owned data on top of ttf-...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Stefano Figura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1887352
Blocks: 1880718
TreeView+ depends on / blocked
 
Reported: 2020-10-12 08:23 UTC by Fabio Valentini
Modified: 2020-10-13 13:45 UTC (History)
2 users (show)

Fixed In Version: rust-owned_ttf_parser-0.6.0-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-13 13:45:53 UTC
Type: ---
stefano: fedora-review+


Attachments (Terms of Use)

Description Fabio Valentini 2020-10-12 08:23:37 UTC
Spec URL: https://decathorpe.fedorapeople.org/packages/rust-owned_ttf_parser.spec
SRPM URL: https://decathorpe.fedorapeople.org/packages/rust-owned_ttf_parser-0.6.0-1.fc32.src.rpm

Description:
ttf-parser plus support for owned data.

Fedora Account System Username: decathorpe

The rusttype crate (review pending) still requires version 0.6.0 of this crate, so I cannot package the latest version (0.8.x) right now.

Comment 1 Stefano Figura 2020-10-12 12:02:51 UTC
Package Review
==============

Reviewer notes:

- ACCEPT

This seems like fedora-review is getting confused for some reason:
- If your application is a C or C++ application you must list a
  BuildRequires against gcc, gcc-c++ or clang.
  Note: No gcc, gcc-c++ or clang found in BuildRequires
  See: https://docs.fedoraproject.org/en-US/packaging-guidelines/C_and_C++/

This SHOULD item is because "rusttype" requires this particular version of `owned_ttf_parser`:
[!]: Latest version is packaged.

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- If your application is a C or C++ application you must list a
  BuildRequires against gcc, gcc-c++ or clang.
  Note: No gcc, gcc-c++ or clang found in BuildRequires
  See: https://docs.fedoraproject.org/en-US/packaging-guidelines/C_and_C++/


===== MUST items =====

C/C++:
[-]: Package does not contain kernel modules.
[-]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "Expat License". 63 files have unknown
     license. Detailed output of licensecheck in
     /var/home/returntrip/devel/packaging/reviews/1887352-rust-ttf-
     parser/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[-]: If the package is under multiple licenses, the licensing breakdown
     must be documented in the spec.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in rust-
     ttf-parser-devel , rust-ttf-parser+default-devel , rust-ttf-
     parser+std-devel
[?]: Package functions as described.
[!]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Sources are verified with gpgverify first in %prep if upstream
     publishes signatures.
     Note: gpgverify is not used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: rust-ttf-parser-devel-0.6.2-1.fc34.noarch.rpm
          rust-ttf-parser+default-devel-0.6.2-1.fc34.noarch.rpm
          rust-ttf-parser+std-devel-0.6.2-1.fc34.noarch.rpm
          rust-ttf-parser-0.6.2-1.fc34.src.rpm
rust-ttf-parser-devel.noarch: W: invalid-url URL: https://crates.io/crates/ttf-parser HTTP Error 404: Not Found
rust-ttf-parser-devel.noarch: W: hidden-file-or-dir /usr/share/cargo/registry/ttf-parser-0.6.2/.cargo-checksum.json
rust-ttf-parser+default-devel.noarch: W: invalid-url URL: https://crates.io/crates/ttf-parser HTTP Error 404: Not Found
rust-ttf-parser+default-devel.noarch: W: no-documentation
rust-ttf-parser+std-devel.noarch: W: invalid-url URL: https://crates.io/crates/ttf-parser HTTP Error 404: Not Found
rust-ttf-parser+std-devel.noarch: W: no-documentation
rust-ttf-parser.src: W: invalid-url URL: https://crates.io/crates/ttf-parser HTTP Error 404: Not Found
4 packages and 0 specfiles checked; 0 errors, 7 warnings.




Rpmlint (installed packages)
----------------------------
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
rust-ttf-parser+default-devel.noarch: W: invalid-url URL: https://crates.io/crates/ttf-parser <urlopen error [Errno -3] Temporary failure in name resolution>
rust-ttf-parser+default-devel.noarch: W: no-documentation
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
rust-ttf-parser-devel.noarch: W: invalid-url URL: https://crates.io/crates/ttf-parser <urlopen error [Errno -3] Temporary failure in name resolution>
rust-ttf-parser-devel.noarch: W: hidden-file-or-dir /usr/share/cargo/registry/ttf-parser-0.6.2/.cargo-checksum.json
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
rust-ttf-parser+std-devel.noarch: W: invalid-url URL: https://crates.io/crates/ttf-parser <urlopen error [Errno -3] Temporary failure in name resolution>
rust-ttf-parser+std-devel.noarch: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 6 warnings.



Source checksums
----------------
https://crates.io/api/v1/crates/ttf-parser/0.6.2/download#/ttf-parser-0.6.2.crate :
  CHECKSUM(SHA256) this package     : 3e5d7cd7ab3e47dda6e56542f4bbf3824c15234958c6e1bd6aaa347e93499fdc
  CHECKSUM(SHA256) upstream package : 3e5d7cd7ab3e47dda6e56542f4bbf3824c15234958c6e1bd6aaa347e93499fdc


Requires
--------
rust-ttf-parser-devel (rpmlib, GLIBC filtered):
    cargo

rust-ttf-parser+default-devel (rpmlib, GLIBC filtered):
    cargo
    crate(ttf-parser)
    crate(ttf-parser/std)

rust-ttf-parser+std-devel (rpmlib, GLIBC filtered):
    cargo
    crate(ttf-parser)



Provides
--------
rust-ttf-parser-devel:
    crate(ttf-parser)
    rust-ttf-parser-devel

rust-ttf-parser+default-devel:
    crate(ttf-parser/default)
    rust-ttf-parser+default-devel

rust-ttf-parser+std-devel:
    crate(ttf-parser/std)
    rust-ttf-parser+std-devel



Generated by fedora-review 0.7.5 (5fa5b7e) last change: 2020-02-16
Command line :/usr/bin/fedora-review -b 1887352
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, C/C++, Shell-api
Disabled plugins: Perl, R, Python, PHP, Haskell, Ocaml, Java, SugarActivity, fonts
Disabled flags: EPEL6, EPEL7, DISTTAG, BATCH, EXARCH

Comment 2 Stefano Figura 2020-10-12 12:07:57 UTC
Apologies - I got confused by the name. Setting back to review pending.

Comment 3 Stefano Figura 2020-10-13 09:19:36 UTC
- ACCEPT

Reviewer's Note:

- Latest version is not packaged because: "rusttype crate (review pending) still requires version 0.6.0 of this crate"

[!]: Latest version is packaged.

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated". 12 files have unknown license. Detailed
     output of licensecheck in
     /var/home/returntrip/devel/packaging/reviews/1887353-rust-
     owned_ttf_parser/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in rust-
     owned_ttf_parser-devel , rust-owned_ttf_parser+default-devel , rust-
     owned_ttf_parser+std-devel
[?]: Package functions as described.
[!]: Latest version is packaged.
[-]: Package does not include license text files separate from upstream.
[-]: Sources are verified with gpgverify first in %prep if upstream
     publishes signatures.
     Note: gpgverify is not used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: rust-owned_ttf_parser-devel-0.6.0-1.fc34.noarch.rpm
          rust-owned_ttf_parser+default-devel-0.6.0-1.fc34.noarch.rpm
          rust-owned_ttf_parser+std-devel-0.6.0-1.fc34.noarch.rpm
          rust-owned_ttf_parser-0.6.0-1.fc34.src.rpm
rust-owned_ttf_parser-devel.noarch: W: spelling-error Summary(en_US) ttf -> ttys
rust-owned_ttf_parser-devel.noarch: W: spelling-error %description -l en_US ttf -> ttys
rust-owned_ttf_parser-devel.noarch: W: invalid-url URL: https://crates.io/crates/owned_ttf_parser HTTP Error 404: Not Found
rust-owned_ttf_parser-devel.noarch: W: hidden-file-or-dir /usr/share/cargo/registry/owned_ttf_parser-0.6.0/.cargo-checksum.json
rust-owned_ttf_parser+default-devel.noarch: W: spelling-error Summary(en_US) ttf -> ttys
rust-owned_ttf_parser+default-devel.noarch: W: spelling-error %description -l en_US ttf -> ttys
rust-owned_ttf_parser+default-devel.noarch: W: invalid-url URL: https://crates.io/crates/owned_ttf_parser HTTP Error 404: Not Found
rust-owned_ttf_parser+default-devel.noarch: W: no-documentation
rust-owned_ttf_parser+std-devel.noarch: W: spelling-error Summary(en_US) ttf -> ttys
rust-owned_ttf_parser+std-devel.noarch: W: spelling-error %description -l en_US ttf -> ttys
rust-owned_ttf_parser+std-devel.noarch: W: invalid-url URL: https://crates.io/crates/owned_ttf_parser HTTP Error 404: Not Found
rust-owned_ttf_parser+std-devel.noarch: W: no-documentation
rust-owned_ttf_parser.src: W: spelling-error Summary(en_US) ttf -> ttys
rust-owned_ttf_parser.src: W: spelling-error %description -l en_US ttf -> ttys
rust-owned_ttf_parser.src: W: description-shorter-than-summary
rust-owned_ttf_parser.src: W: invalid-url URL: https://crates.io/crates/owned_ttf_parser HTTP Error 404: Not Found
4 packages and 0 specfiles checked; 0 errors, 16 warnings.




Rpmlint (installed packages)
----------------------------
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
rust-owned_ttf_parser-devel.noarch: W: spelling-error Summary(en_US) ttf -> ttys
rust-owned_ttf_parser-devel.noarch: W: spelling-error %description -l en_US ttf -> ttys
rust-owned_ttf_parser-devel.noarch: W: invalid-url URL: https://crates.io/crates/owned_ttf_parser <urlopen error [Errno -3] Temporary failure in name resolution>
rust-owned_ttf_parser-devel.noarch: W: hidden-file-or-dir /usr/share/cargo/registry/owned_ttf_parser-0.6.0/.cargo-checksum.json
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
rust-owned_ttf_parser+std-devel.noarch: W: spelling-error Summary(en_US) ttf -> ttys
rust-owned_ttf_parser+std-devel.noarch: W: spelling-error %description -l en_US ttf -> ttys
rust-owned_ttf_parser+std-devel.noarch: W: invalid-url URL: https://crates.io/crates/owned_ttf_parser <urlopen error [Errno -3] Temporary failure in name resolution>
rust-owned_ttf_parser+std-devel.noarch: W: no-documentation
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
rust-owned_ttf_parser+default-devel.noarch: W: spelling-error Summary(en_US) ttf -> ttys
rust-owned_ttf_parser+default-devel.noarch: W: spelling-error %description -l en_US ttf -> ttys
rust-owned_ttf_parser+default-devel.noarch: W: invalid-url URL: https://crates.io/crates/owned_ttf_parser <urlopen error [Errno -3] Temporary failure in name resolution>
rust-owned_ttf_parser+default-devel.noarch: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 12 warnings.



Source checksums
----------------
https://crates.io/api/v1/crates/owned_ttf_parser/0.6.0/download#/owned_ttf_parser-0.6.0.crate :
  CHECKSUM(SHA256) this package     : 9f923fb806c46266c02ab4a5b239735c144bdeda724a50ed058e5226f594cde3
  CHECKSUM(SHA256) upstream package : 9f923fb806c46266c02ab4a5b239735c144bdeda724a50ed058e5226f594cde3


Requires
--------
rust-owned_ttf_parser-devel (rpmlib, GLIBC filtered):
    (crate(ttf-parser) >= 0.6.0 with crate(ttf-parser) < 0.7.0)
    cargo

rust-owned_ttf_parser+default-devel (rpmlib, GLIBC filtered):
    (crate(ttf-parser/default) >= 0.6.0 with crate(ttf-parser/default) < 0.7.0)
    cargo
    crate(owned_ttf_parser)
    crate(owned_ttf_parser/std)

rust-owned_ttf_parser+std-devel (rpmlib, GLIBC filtered):
    cargo
    crate(owned_ttf_parser)



Provides
--------
rust-owned_ttf_parser-devel:
    crate(owned_ttf_parser)
    rust-owned_ttf_parser-devel

rust-owned_ttf_parser+default-devel:
    crate(owned_ttf_parser/default)
    rust-owned_ttf_parser+default-devel

rust-owned_ttf_parser+std-devel:
    crate(owned_ttf_parser/std)
    rust-owned_ttf_parser+std-devel



Generated by fedora-review 0.7.5 (5fa5b7e) last change: 2020-02-16
Command line :/usr/bin/fedora-review -o --enablerepo local -b 1887353
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: C/C++, SugarActivity, Python, Ocaml, Perl, Haskell, Java, R, PHP, fonts
Disabled flags: EPEL6, EPEL7, DISTTAG, BATCH, EXARCH

Comment 4 Gwyn Ciesla 2020-10-13 13:08:29 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/rust-owned_ttf_parser

Comment 5 Fabio Valentini 2020-10-13 13:45:53 UTC
Built for rawhide:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1624759


Note You need to log in before you can comment on or make changes to this bug.