Bug 188739 - amaya rpm package does not build
amaya rpm package does not build
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: amaya (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-12 13:47 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-12 14:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-04-12 13:47:15 EDT
Description of problem: 
 
The current version of amaya does not build due to a compile error. 
 
Version-Release number of selected component (if applicable): 
amaya-9.1-12.fc5.src.rpm 
 
How reproducible: 100% 
 
 
Steps to Reproduce: 
1. rpmbuild --rebuild source rpm or rpmbuild -bb spec.file 
   
Actual results: 
 
Build fails with: 
 
signed int, unsigned int, unsigned int, unsigned int, XpmColor*, 
xpmHashTable*, XImage*, Pixel*, XImage*, Pixel*)': 
../../thotlib/image/xpmcreate.c:2429: error: cast from 'void*' to 'unsigned 
int' loses precision 
../../thotlib/image/xpmcreate.c:2432: error: cast from 'void*' to 'unsigned 
int' loses precision 
make[1]: *** [image/xpmcreate.o] Error 1 
make[1]: Leaving directory 
`/usr/src/redhat/BUILD/amaya-9.1/Amaya/gtk-build/thotlib' 
make: *** [thotlib] Error 2 
error: Bad exit status from /var/tmp/rpm-tmp.71624 (%build) 
 
Expected results: build should complete. 
 
Additional info:
Comment 1 Aurelien Bompard 2006-04-12 14:02:56 EDT
This package is orphaned since september 2005:
http://fedoraproject.org/wiki/Extras/OrphanedPackages
If someone finds the fix, fine. Else, we should probably ExcludArch ia64.

Note You need to log in before you can comment on or make changes to this bug.