Bug 1887461 - [sig-storage] In-tree Volumes [Driver: aws] [Testpattern: Dynamic PV (default fs)(allowExpansion)] volume-expand Verify if offline PVC expansion works
Summary: [sig-storage] In-tree Volumes [Driver: aws] [Testpattern: Dynamic PV (default...
Keywords:
Status: CLOSED DUPLICATE of bug 1879192
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.7.0
Assignee: Hemant Kumar
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-12 14:30 UTC by Jan Chaloupka
Modified: 2020-10-13 20:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
[sig-storage] In-tree Volumes [Driver: aws] [Testpattern: Dynamic PV (default fs)(allowExpansion)] volume-expand Verify if offline PVC expansion works
Last Closed: 2020-10-13 20:35:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Chaloupka 2020-10-12 14:30:53 UTC
test:
[sig-storage] In-tree Volumes [Driver: aws] [Testpattern: Dynamic PV (default fs)(allowExpansion)] volume-expand Verify if offline PVC expansion works 

is failing frequently in CI, see search results:
https://search.ci.openshift.org/?maxAge=168h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job&search=%5C%5Bsig-storage%5C%5D+In-tree+Volumes+%5C%5BDriver%3A+aws%5C%5D+%5C%5BTestpattern%3A+Dynamic+PV+%5C%28default+fs%5C%29%5C%28allowExpansion%5C%29%5C%5D+volume-expand+Verify+if+offline+PVC+expansion+works


https://search.ci.openshift.org/?maxAge=168h&context=1&type=bug%2Bjunit&name=4.5&maxMatches=5&maxBytes=20971520&groupBy=job&search=%5C%5Bsig-storage%5C%5D+In-tree+Volumes+%5C%5BDriver%3A+aws%5C%5D+%5C%5BTestpattern%3A+Dynamic+PV+%5C%28default+fs%5C%29%5C%28allowExpansion%5C%29%5C%5D+volume-expand+Verify+if+offline+PVC+expansion+works

https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-mirrors-4.5/1315055827509317632


```
fail [k8s.io/kubernetes/test/e2e/storage/testsuites/volume_expand.go:211]: while recreating pod for resizing
Unexpected error:
    <*errors.errorString | 0xc001fc96d0>: {
        s: "pod \"security-context-44e761bb-d4ed-44d6-9ed2-bb0a00b6baf7\" is not Running: timed out waiting for the condition",
    }
    pod "security-context-44e761bb-d4ed-44d6-9ed2-bb0a00b6baf7" is not Running: timed out waiting for the condition
occurred
```

Kubelet logs:

```
Oct 10 23:20:45.726659 ip-10-0-161-90 hyperkube[1469]: E1010 23:20:45.726601    1469 kubelet.go:1700] Unable to attach or mount volumes for pod "security-context-44e761bb-d4ed-44d6-9ed2-bb0a00b6baf7_e2e-volume-expand-6329(54a9e9b0-0a76-4752-98ce-000ebb4cd89f)": unmounted volumes=[volume1], unattached volumes=[default-token-wjp5f volume1]: timed out waiting for the condition; skipping pod
Oct 10 23:23:04.060231 ip-10-0-161-90 hyperkube[1469]: E1010 23:23:04.060162    1469 kubelet.go:1700] Unable to attach or mount volumes for pod "security-context-44e761bb-d4ed-44d6-9ed2-bb0a00b6baf7_e2e-volume-expand-6329(54a9e9b0-0a76-4752-98ce-000ebb4cd89f)": unmounted volumes=[volume1], unattached volumes=[volume1 default-token-wjp5f]: timed out waiting for the condition; skipping pod
Oct 10 23:25:21.063553 ip-10-0-161-90 hyperkube[1469]: E1010 23:25:21.063430    1469 kubelet.go:1700] Unable to attach or mount volumes for pod "security-context-44e761bb-d4ed-44d6-9ed2-bb0a00b6baf7_e2e-volume-expand-6329(54a9e9b0-0a76-4752-98ce-000ebb4cd89f)": unmounted volumes=[volume1 default-token-wjp5f], unattached volumes=[volume1 default-token-wjp5f]: timed out waiting for the condition; skipping pod
```

Could be the same underlying reason as for https://bugzilla.redhat.com/show_bug.cgi?id=1887454

Comment 4 Hemant Kumar 2020-10-13 20:35:35 UTC

*** This bug has been marked as a duplicate of bug 1879192 ***


Note You need to log in before you can comment on or make changes to this bug.