Bug 18877 - Symlink causes unhandled exception during upgrade.
Symlink causes unhandled exception during upgrade.
Status: CLOSED DUPLICATE of bug 13071
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
All Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
http://devel.yellowdoglinux.com/~cste...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 05:28 EDT by Charles Stevenson
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 16:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Stevenson 2000-10-11 05:28:27 EDT
I have /tmp linked to /var/tmp in my existing installation. When anaconda
creates /mnt/sysimage/foo if it is linked to /bar/feh in the real file
system it also links it to /bar/feh when recreated in /mnt/sysimage.  This
causes anaconda to look for a file within the ramdisk instead of within the
/mnt/sysimage/ directory. Which results in an unhandled exception.

In the anaconda inspired installer I've been working on for Yellow Dog I
use a chroot to avoid problems like this.

Possible Solution: Boot old Linux install and remove symlink... then add it
back after upgrade... possibly create the directory within the ramdisk from
the installer shell... either way I dont think there is a good solution or
workaround in the 7.0 installer.

Good luck :)

Best Regards,
Charles Stevenson
Software Engineer
--  
  Terra Soft Solutions, Inc.
  http://www.terrasoftsolutions.com/

  Yellow Dog Linux
  "The Ultimate Companion for a Dedicated Server"
  http://www.yellowdoglinux.com/

  Black Lab Linux
  Workstations and advanced, Parallel Solutions
  http://www.blacklablinux.com/
Comment 1 Charles Stevenson 2000-10-11 05:46:54 EDT
Possible only a rare case if user has /tmp linked elsewhere...
Comment 2 Charles Stevenson 2000-10-11 05:51:02 EDT
It happened when anaconda tried to write /mnt/sysimage/tmp/upgrade.log since
/mnt/sysimage/tmp -> /var/tmp
Comment 3 Charles Stevenson 2000-10-11 06:11:30 EDT
I noticed a similar issue #10308 which was closed (WONT) with the explanation
that RPM cannot follow symlinks such as /home -> /usr/home... when in fact it is
due to the means by which anaconda mounts the root filesystem within
/mnt/sysimage. I dont have the source code handy but perhaps later I will try
and submit a patch if time permits.
Comment 4 Michael Fulbright 2000-10-18 16:42:45 EDT

*** This bug has been marked as a duplicate of 13071 ***

Note You need to log in before you can comment on or make changes to this bug.