Bug 1887733 - Is it possible to use RHEL7 as an ansible server to install OCP4.5 on RHOSP13?
Summary: Is it possible to use RHEL7 as an ansible server to install OCP4.5 on RHOSP13?
Keywords:
Status: CLOSED DUPLICATE of bug 1887731
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: aos-install
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-13 08:42 UTC by ryoji noma
Modified: 2020-10-13 08:47 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-13 08:47:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ryoji noma 2020-10-13 08:42:59 UTC
Version:

OCP4.5
RHSOP13
RHEL7

Platform:

RHOSP

Please specify:
UPI

What happened?

Is it possible to use RHEL7 as an ansible server to install OCP4.5 on RHOSP13? When the customer installed, ansible output the following error.

```
fatal: [localhost]: FAILED! => {"changed": false, "msg": "To utilize this module, the installed version ofthe openstacksdk library MnUST be >=0.12.0"}
```

Aaccording to the documentation below, RHOSP13 tools for RHEL7 openstacksdk version is 0.11.3.

4.8. RED HAT OPENSTACK PLATFORM 13 TOOLS FOR RHEL 7 SERVER (RPMS)
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/13/html/package_manifest/rhel-7-server-openstack-13-tools-rpms

What did you expect to happen?

How to install OCP4.5 on RHOSP13 using RHEL7 as an ansible server? If it is impossible, It should be written in the documentation. 

The customer used the documentation below.

Downloading playbook dependencies
https://docs.openshift.com/container-platform/4.5/installing/installing_openstack/installing-openstack-user.html#installation-osp-downloading-modules_installing-openstack-user

Comment 1 ryoji noma 2020-10-13 08:47:45 UTC

*** This bug has been marked as a duplicate of bug 1887731 ***


Note You need to log in before you can comment on or make changes to this bug.